Bug 416924 - The server is not connecting
Summary: The server is not connecting
Status: RESOLVED NOT A BUG
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: akonadiconsole (show other bugs)
Version: 5.13.40
Platform: Gentoo Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-29 18:51 UTC by Aom1970
Modified: 2020-01-30 20:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
When I try to open the server it tells me the akonadi personal information management service is not available. (4.76 KB, text/plain)
2020-01-29 18:51 UTC, Aom1970
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aom1970 2020-01-29 18:51:42 UTC
Created attachment 125526 [details]
When I try to open the server it tells me the akonadi personal information management service is not available.

SUMMARY


STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS

Linux/KDE Plasma: 5
(available in About System)
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2

ADDITIONAL INFORMATION
Comment 1 Christophe Giboudeaux 2020-01-29 21:11:18 UTC
>Database driver not found.
>Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration.
>The following drivers are installed: QSQLITE, QPSQL, QPSQL7.
>Make sure the required driver is installed.

This looks like a Gentoo issue.
Comment 2 Andreas Sturmlechner 2020-01-30 20:44:48 UTC
Not a bug.

kde-apps/akonadi installation gives appropriate steps for how to configure your akonadi instance, depending on the use flags you have set.

Example from my system:
 * You can select the storage backend in ~/.config/akonadi/akonadiserverrc.
 * Available drivers are:
 *   QPSQL
 *  has been set as your default akonadi storage backend.
Comment 3 Andreas Sturmlechner 2020-01-30 20:46:28 UTC
The provided log indicates that kde-apps/akonadi was built exactly without USE=mysql.