Bug 416878 - Pager widget does not always switch to hovered virtual desktop while I drag something
Summary: Pager widget does not always switch to hovered virtual desktop while I drag s...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Pager (show other bugs)
Version: 5.23.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: ratijas
URL:
Keywords: wayland
: 456489 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-28 19:32 UTC by Patrick Silva
Modified: 2022-07-13 17:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6 5.25.3 5.26


Attachments
screen recording (2.94 MB, video/webm)
2020-01-28 19:32 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-01-28 19:32:39 UTC
Created attachment 125499 [details]
screen recording

SUMMARY
Watch the attached screen recording please.
Pager always switches to the first hovered VD.
But it does not if I hover over another VD without move the cursor outside the Pager before. If I move cursor outside the Pager and hover over the same VD hovered when switching failed, then Pager switches to it as expected.


EXPECTED RESULT
Pager always switches virtual desktops on mouseover

Operating System: Arch Linux 
KDE Plasma Version: 5.17.90
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1
Comment 1 Patrick Silva 2021-05-22 19:27:07 UTC
I'm not sure if switching to hovered virtual desktop while dragging something
is intentional or not, but this behavior is still inconsistent.

1. set 3 virtual desktops and 1 row in Virtual Desktops KCM
2. while using VD1, open an app
3. drag the entry of the app used in the step 2 to VD3 and do NOT release
the mouse button (Pager switches to hovered VD3 after a few milliseconds)
4. without moving cursor outside Pager widget, drag the app to VD2:
now Pager widget does not switch to hovered VD2.
5. move the app outside Plasma panel
6. drag the app to VD2 again: now Pager switches to VD2 after a few milliseconds
Comment 2 Patrick Silva 2021-05-22 19:28:45 UTC
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 3 Fushan Wen 2022-01-16 15:52:41 UTC
Can't reproduce on X11.
Comment 4 ratijas 2022-07-08 19:35:45 UTC
*** Bug 456489 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2022-07-09 15:44:49 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1027
Comment 6 ratijas 2022-07-09 17:51:42 UTC
Git commit 4f190cdf9a40d9a02da311e69e9b0061121ed8fb by ivan tkachenko.
Committed on 09/07/2022 at 15:38.
Pushed by ratijas into branch 'master'.

[applets/pager] Fix switching desktops on drag & hover

Access to global variables holding the state for currently hovered
desktop is poorly ordered by QML DropArea, so an additional check is
needed to ensure a component is only cleaning up after itself.
FIXED-IN: 5.24.6 5.25.3 5.26

M  +5    -2    applets/pager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/4f190cdf9a40d9a02da311e69e9b0061121ed8fb
Comment 7 ratijas 2022-07-09 17:52:58 UTC
Git commit 3ac4cbb6cc7f30109efaaeb4b6f63ae3de26d515 by ivan tkachenko.
Committed on 09/07/2022 at 17:51.
Pushed by ratijas into branch 'Plasma/5.24'.

[applets/pager] Fix switching desktops on drag & hover

Access to global variables holding the state for currently hovered
desktop is poorly ordered by QML DropArea, so an additional check is
needed to ensure a component is only cleaning up after itself.
FIXED-IN: 5.24.6 5.25.3 5.26
(cherry picked from commit 4f190cdf9a40d9a02da311e69e9b0061121ed8fb)

M  +5    -2    applets/pager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/3ac4cbb6cc7f30109efaaeb4b6f63ae3de26d515
Comment 8 ratijas 2022-07-09 17:53:31 UTC
Git commit a96da36970a4d87825946df3fb65da230f6fa123 by ivan tkachenko.
Committed on 09/07/2022 at 17:51.
Pushed by ratijas into branch 'Plasma/5.25'.

[applets/pager] Fix switching desktops on drag & hover

Access to global variables holding the state for currently hovered
desktop is poorly ordered by QML DropArea, so an additional check is
needed to ensure a component is only cleaning up after itself.
FIXED-IN: 5.24.6 5.25.3 5.26
(cherry picked from commit 4f190cdf9a40d9a02da311e69e9b0061121ed8fb)

M  +5    -2    applets/pager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/a96da36970a4d87825946df3fb65da230f6fa123