Bug 416746 - Summary values are not updated for investment transaction of type interest income
Summary: Summary values are not updated for investment transaction of type interest in...
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 5.0.8
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-25 12:48 UTC by Thomas Baumgart
Modified: 2020-06-05 04:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Baumgart 2020-01-25 12:48:34 UTC
SUMMARY
Entering fees for an investment transaction of type "Interest income" does not update the summary values

STEPS TO REPRODUCE
1. Start new investment transaction
2. Select type "Interest income"
3. Enter interest category and amount
4. Enter split transaction for fees with two splits and some amounts
5. Leave split transaction editor with OK

OBSERVED RESULT
Amount for fees and summary are not updated

EXPECTED RESULT
Amount for fees and summary are shown and updated
Comment 1 Thomas Baumgart 2020-01-25 13:23:13 UTC
Git commit b3988b80e81cb294597271c11f1f9c9d4af50fae by Thomas Baumgart.
Committed on 25/01/2020 at 13:22.
Pushed by tbaumgart into branch '5.0'.

Show all required widgets

Since some widgets were hidden when required, the update of certain
values did not work correctly in all circumstances.
FIXED-IN: 5.0.9

M  +3    -2    kmymoney/dialogs/investactivities.cpp

https://commits.kde.org/kmymoney/b3988b80e81cb294597271c11f1f9c9d4af50fae
Comment 2 Thomas Baumgart 2020-01-25 13:27:31 UTC
Git commit 1f23553cebabee02020cdb3bbd20633ae31bf184 by Thomas Baumgart.
Committed on 25/01/2020 at 13:23.
Pushed by tbaumgart into branch 'master'.

Show all required widgets

Since some widgets were hidden when required, the update of certain
values did not work correctly in all circumstances.
FIXED-IN: 5.0.9
(cherry picked from commit b3988b80e81cb294597271c11f1f9c9d4af50fae)

M  +3    -2    kmymoney/dialogs/investactivities.cpp

https://commits.kde.org/kmymoney/1f23553cebabee02020cdb3bbd20633ae31bf184