Bug 416510 - Klipper applet closes itself when I click on a history item while the system tray popup is pinned open
Summary: Klipper applet closes itself when I click on a history item while the system ...
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Applications
Component: plasma-widget (show other bugs)
Version: 5.18.5
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: usability
: 417068 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-20 21:40 UTC by popov895
Modified: 2020-06-13 02:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.19.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description popov895 2020-01-20 21:40:34 UTC
SUMMARY

When I pin a Klipper widget and then click on a history item, the Klipper widget closes.

STEPS TO REPRODUCE
1. Add some items to the Klipper
2. Open Llipper widget
3. Check "Keep Open" button in the top right corner
4. Press any item in the Klipper widget

OBSERVED RESULT

The Klipper widget closes.

EXPECTED RESULT

The Klipper widget remains opened.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: KDE Neon 5.17
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.13.2
Comment 1 Nate Graham 2020-01-21 18:11:19 UTC
Confirmed. I think this is intentional, but clearly when you pin open the system tray popup, you're announcing your desire to have it stay open, and it's not respecting that desire. I wonder if this is fixable.
Comment 2 Nate Graham 2020-02-05 19:58:12 UTC
*** Bug 417068 has been marked as a duplicate of this bug. ***
Comment 3 popov895 2020-03-28 21:59:12 UTC
Can anybody suggest me how to check if the plasmoid is pinned or not?
Comment 4 popov895 2020-03-29 19:17:20 UTC
Submitted a patch: https://phabricator.kde.org/D28408
Comment 5 Nate Graham 2020-03-31 15:30:08 UTC
Git commit 175424169d18766565a9b105b76136c4113515e1 by Nate Graham, on behalf of Eugene Popov.
Committed on 31/03/2020 at 15:30.
Pushed by ngraham into branch 'master'.

[applets/clipboard]: Fix applet closing itself when clicking on a history item while the tray popup is pinned open

Summary:
When I pin a Klipper widget and then click on a history item, the Klipper widget closes.

To fix this bug, we need to check if Klipped is pinned, but to be able to do this, we also need to "forward" the pinned state from the SystemTray applet to the Klipper applet.
FIXED-IN: 5.19.0

Reviewers: ngraham, #plasma

Reviewed By: ngraham

Subscribers: davidedmundson, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D28408

M  +2    -1    applets/clipboard/contents/ui/ClipboardItemDelegate.qml
M  +4    -0    applets/systemtray/package/contents/ui/main.qml

https://commits.kde.org/plasma-workspace/175424169d18766565a9b105b76136c4113515e1
Comment 6 popov895 2020-06-12 15:51:00 UTC
Can be reproduced on Plasma 5.18.5 LTS
Comment 7 Nate Graham 2020-06-13 02:01:26 UTC
It's fixed in 5.19