Bug 416461 - [5.18] KDE wallet not unlocked on login
Summary: [5.18] KDE wallet not unlocked on login
Status: NEEDSINFO WAITINGFORINFO
Alias: None
Product: kwallet-pam
Classification: Unclassified
Component: general (show other bugs)
Version: 5.18.3
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-19 15:00 UTC by Richard Ullger
Modified: 2022-06-21 16:34 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
journalctl -b | grep kwallet (3.52 KB, text/plain)
2020-04-11 00:07 UTC, Henrique Sant'Anna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Ullger 2020-01-19 15:00:12 UTC
SUMMARY
The KDE wallet used to be automatically unlocked using the login password but since upgrading to plasma 5.17.90 this is no longer the case and the wallet password has to be entered every time you log in. This prevents automatic login to the wireless network.

STEPS TO REPRODUCE
1. Upgrade to 5.17.90
2. Log in

OBSERVED RESULT
Wallet manager requests entry of password for kded5.

EXPECTED RESULT
Wallet should be automatically unlocked using the login password which should not need to be entered separately.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.17.90
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.0
Kernel Version: 5.4.13-arch1-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5 CPU M 430 @ 2.27GHz
Memory: 7.5 GiB of RAM

ADDITIONAL INFORMATION
Arch kde-unstable repo
Comment 1 Dante Igashu 2020-02-20 10:12:50 UTC
I have the same problem, but it started after I updated to Plasma 5.18.
I login and I get a popup windows almost immediately, long before the session even loads asking me for the password to open "kdewallet" because "kded5" is requesting to get it opened.
I have the same problem in two of my three computers at this moment.

SOFTWARE/OS VERSIONS
Operating System: EndeavourOS 
KDE Plasma Version: 5.18.1-1
KDE Frameworks Version: 5.67.0-2
Qt Version: 5.14.1-1
Kernel Version: 5.5.4.arch1-1
OS Type: 64-bit
Processors: 4 x Intel Celeron CPU N2930 @ 1.83GHz
Memory: 7.7 GiB of RAM

ADDITIONAL INFORMATION
In my case, I reinstalled the OS, expecting the problem to be solved, but I kept all my files in my home partition and the problems is still there. There is an apparently outdated post here:

https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login

in the last line it says that if you want the thing to stop asking you for the passwords at every login, to erase the folder called "kwallet", but it doesn't exist, or at least is not located there, I was wondering if that folder exists somewhere else and if deleting it would solve the problem, but I just found two "KWallet" folders located in the /usr folder, so I guess I shouldn't mess with any of those.
Could it be that deleting a folder would solve the problem?

THANKS IN ADVANCE! :D
Comment 2 Richard Ullger 2020-02-21 20:39:06 UTC
The kde wallet in plasma 5.18 is stored in ~/.local/share/kwalletd/. Renaming this folder will cause the directory to be recreated and a new wallet to be set up.

Contrary to the Arch wiki page, you have the option to use a gpg key or blowfish encryption, with the gpg option being the default. The problem with using a gpg key is that you will be prompted to enter the gpg passphrase every time you log in.

Recreating the wallet using blowfish encryption and you're back to entering your login password every time you log in.

This regression occurred when I upgraded to 5.17.90 (5.18 beta) and persists in 5.18 and 5.18.1.
Comment 3 francaco 2020-02-21 20:49:12 UTC
I am in KDE Neon 5.18.1 and still have this problem, that started after upgrading to 5.18
Comment 4 Dante Igashu 2020-02-25 19:25:05 UTC
I've noticed that the problem exist only for the account that updated plasma to plasma 5.18 in one of my computers, as in that one I have 4 users and the other three get the wallet unlocked automatically at login, but not the one of the user that updated. In my other computers I only have one user so I hadn't noticed that.
May I upload some log files so you can take a look?
could you tell me what command to use to provide log files?
THANKS in advance! :D
Comment 5 abc123 2020-03-12 18:11:05 UTC
having same problem on fresh install of arch linux....plasma 5.18.3

after login it is asking for password to unlock the kdewallet(kde5 requesting it)
It should be unlock automatically
Comment 6 medin 2020-03-16 19:34:17 UTC
Same problem here after upgrade to Plasma 5.18.3, on 5.17 it was working fine without entering password for kwallet.
Comment 7 Donegali 2020-03-16 19:43:58 UTC
I have the same issue, after updating Manjaro KDE Plasma to 5.18.3, kded5 is now requesting access to Kwallet on every login. Disabling Kwallet means I need to enter my network password every login.

Manjaro KDE Plasma 5.18.3 stable repo
Comment 8 Alex 2020-03-17 19:21:46 UTC
The same issue for me. Appears after last update my Manjaro KDE to 5.18.3
Comment 9 Mikhail 2020-03-20 11:39:35 UTC
Same on Manjaro.
KDE 5.18.3
Comment 10 David Edmundson 2020-03-20 12:35:04 UTC
Please don't add "me too" comments unless you can add some value.

At least include the output of journalctl for the login.

--

If someone is convinced that this is a regression, please perform a bisect to find out what.

--
There is a branch in the kwallet-pam repo called:

davidedmundson/test
building that will simulate the entire login process
Comment 11 Nate Graham 2020-03-20 14:35:10 UTC
Out of curiosity, are the people experiencing this using encrypted home directories?
Comment 12 Richard Ullger 2020-03-20 15:22:54 UTC
(In reply to Nate Graham from comment #11)
> Out of curiosity, are the people experiencing this using encrypted home
> directories?

I myself am not using an encrypted home directory.
Comment 13 medin 2020-03-20 22:17:19 UTC
(In reply to Nate Graham from comment #11)
> Out of curiosity, are the people experiencing this using encrypted home
> directories?

No, I don't use encrypted home folder or encrypted partition.
Comment 14 medin 2020-03-20 22:21:30 UTC
(In reply to David Edmundson from comment #10)
> Please don't add "me too" comments unless you can add some value.
> 
> At least include the output of journalctl for the login.
> 
> --
> 
> If someone is convinced that this is a regression, please perform a bisect
> to find out what.
> 
> --
> There is a branch in the kwallet-pam repo called:
> 
> davidedmundson/test
> building that will simulate the entire login process

How can I extract the login log to post it here ?
Comment 15 Richard Ullger 2020-03-21 00:35:54 UTC
I frequently use my phone for tethering or as a wifi hotspot. Sometimes I forget to activate the network on the phone before logging in on my laptop, so the laptop doesn't get a network connection.

I've noticed that when I then enable the network on the phone, the laptop will obtain a network connection and the wallet will get unlocked without prompting for the password.

When I log in on the laptop and the network is already available on the phone, the password to unlock the wallet will always be prompted.

This is 100% reproducible.

The following entries appear in journalctl when prompted for a password...

kwalletd5[1313]: Application ' "kded5" ' using kwallet without parent window!
.
.
.
sddm[1119]: kwalletd5: Checking for pam module
sddm[1119]: kwalletd5: Got pam-login param
sddm[1119]: kwalletd5: Waiting for hash on 7-
sddm[1119]: kwalletd5: waitingForEnvironment on: 3
sddm[1119]: kwalletd5: client connected
sddm[1119]: kwalletd5: client disconnected
Comment 16 Dante Igashu 2020-03-23 12:54:22 UTC
Hello!

Here my log file after login in: http://ix.io/2f2J

As additional info, I had mentioned that I have four accounts in one computer and that only the one that updated the system had that problem, well, I have two administrators in that computer and after I updated the system with the other administrator account, both accounts have the same problem now, I don't know if this also helps but I thought it could be useful information.
THANKS for your help! :D
Comment 17 medin 2020-03-23 13:58:42 UTC
I have a registered wifi network that my laptop connect to automatically after login in, but when wifi network is unavailable (router off) the kwallet dialog is not displayed.
Comment 18 Bug Janitor Service 2020-04-07 04:33:11 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 19 Dante Igashu 2020-04-07 08:41:54 UTC
I had already added some info and I also added a log file here: http://ix.io/2f2J
Thanks!, hopefully it will get fixed soon :D
Comment 20 Henrique Sant'Anna 2020-04-11 00:07:43 UTC
Created attachment 127437 [details]
journalctl -b | grep kwallet
Comment 21 medin 2020-04-11 00:58:13 UTC
Here is my log :

Apr 11 01:35:16 manjaro-med sddm-helper[1115]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
Apr 11 01:35:16 manjaro-med sddm-helper[1115]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
Apr 11 01:35:17 manjaro-med audit[1115]: USER_START pid=1115 uid=0 auid=1000 ses=2 msg='op=PAM:session_open grantors=pam_loginuid,pam_keyinit,pam_limits,pam_unix,pam_permit,pam_mail,pam_systemd,pam_env,pam_kwallet5 acct="mohamed" exe="/usr/lib/sddm/sddm-helper" hostname=? addr=? terminal=:0 res=success'
Apr 11 01:35:16 manjaro-med sddm-helper[1115]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session
Apr 11 01:35:17 manjaro-med sddm-helper[1127]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
Apr 11 01:35:24 manjaro-med dbus-daemon[1137]: [session uid=1000 pid=1137] Activating service name='org.kde.kwalletd5' requested by ':1.4' (uid=1000 pid=1154 comm="kded5 ")
Apr 11 01:35:25 manjaro-med dbus-daemon[1137]: [session uid=1000 pid=1137] Successfully activated service 'org.kde.kwalletd5'
Apr 11 01:35:26 manjaro-med plasma_session[1235]: org.kde.plasma.session: Starting autostart service  "/etc/xdg/autostart/pam_kwallet_init.desktop" ("/usr/lib/pam_kwallet_init")
Apr 11 01:35:41 manjaro-med kwalletd5[1237]: Application ' "kded5" ' using kwallet without parent window!
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: Checking for pam module
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: Got pam-login param
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: Waiting for hash on 7-
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: waitingForEnvironment on: 3
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: client connected
Apr 11 01:35:42 manjaro-med sddm[1128]: kwalletd5: client disconnected
Comment 22 Oleg Solovyov 2020-04-16 14:41:22 UTC
Can this be a race condition between running kwalletd5 without parameters and running with "--pam-login X Y"?
Comment 23 Oleg Solovyov 2020-04-27 09:06:28 UTC
169d398 in plasma-nm causes the issue
Comment 24 Peter Maiwald 2020-04-30 00:49:12 UTC
Same on Manjaro
Comment 25 Venca B Spam 2020-05-21 10:18:19 UTC
This issue might be related to this one #421856 https://bugs.kde.org/show_bug.cgi?id=421856 which I reported a minute ago. The referred problem is however that the KWallet does not accept the correct password at all.
Comment 26 medin 2020-05-21 13:10:06 UTC
With the following upgrade :

Operating System: Manjaro Linux 
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.70.0
Qt Version: 5.14.2
Kernel Version: 5.6.12-1-MANJARO
OS Type: 64-bit

I don't see this problem anymore.
Comment 27 Richard Ullger 2020-05-21 22:01:00 UTC
Following upgrade I too have not encountered the issue so far.

Operating System: Arch Linux 
KDE Plasma Version: 5.18.90
KDE Frameworks Version: 5.70.0
Qt Version: 5.15.0rc2
Kernel Version: 5.6.14-arch1-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5 CPU M 430 @ 2.27GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics
Comment 28 Piotr Kubowicz 2020-06-20 06:36:59 UTC
I have this problem in Kubuntu 20.04 after upgrading from Kubuntu 19.10. Removing the wallet does not help, so some packages are clearly conflicting with each other. However, a 'fresh' wallet works fine if you just log out and log in, without restarting.

1. Set up a WiFi connection using Network Manager, choose 'Store password for this user only (encrypted)', you will have only 1 entry in KDE wallet:

Network Management
Name-Value Map 802-11-wireless-security
key: psk

2. rm -r ~/.local/share/kwalletd
3. restart computer
4. a dialog appears asking you to create KDE Wallet using classic blowfish or GPG, choose classic
5. enter wifi password to the Network Manager dialog

% journalctl -b | grep kwallet
cze 20 08:23:26 bazyliszek sddm-helper[1638]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
cze 20 08:23:26 bazyliszek sddm-helper[1638]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
cze 20 08:23:26 bazyliszek sddm-helper[1638]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session
cze 20 08:23:26 bazyliszek sddm-helper[1651]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
cze 20 08:23:30 bazyliszek dbus-daemon[1661]: [session uid=1000 pid=1661] Activating service name='org.kde.kwalletd5' requested by ':1.9' (uid=1000 pid=1721 comm="kded5 " label="unconfined")
cze 20 08:23:30 bazyliszek dbus-daemon[1661]: [session uid=1000 pid=1661] Successfully activated service 'org.kde.kwalletd5'
cze 20 08:23:30 bazyliszek org.kde.kwalletd5[1768]: kf5.ki18n: "0 instead of 1 arguments to message {<html><head/><body><...} supplied before conversion."
cze 20 08:23:30 bazyliszek org.kde.kwalletd5[1768]: Application ' "kded5" ' using kwallet without parent window!
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: Checking for pam module
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: Got pam-login param
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: Waiting for hash on 7-
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: waitingForEnvironment on: 3
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: client connected
cze 20 08:23:33 bazyliszek sddm[1652]: kwalletd5: client disconnected
cze 20 08:23:53 bazyliszek org.kde.kwalletd5[1768]: QWizard::field: No such field 'key'
cze 20 08:23:53 bazyliszek org.kde.kwalletd5[1768]: Application ' "kded5" ' using kwallet without parent window!

6. log out, log in

% journalctl -b | grep kwallet
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: Checking for pam module
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: Got pam-login param
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: Waiting for hash on 7-
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: waitingForEnvironment on: 3
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: client connected
cze 20 08:13:25 bazyliszek sddm[3393]: kwalletd5: client disconnected
cze 20 08:13:28 bazyliszek sddm-helper[3389]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_close_session
cze 20 08:13:28 bazyliszek sddm-helper[3389]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
cze 20 08:14:06 bazyliszek sddm-helper[4239]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
cze 20 08:14:06 bazyliszek sddm-helper[4239]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
cze 20 08:14:06 bazyliszek sddm-helper[4239]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session
cze 20 08:14:07 bazyliszek sddm-helper[4256]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket

7. OK: wifi connects automatically
8. restart computer, log in with your password
9. BUG: a dialog appears saying "The application 'kded5' has requested to open the wallet 'kdewallet'.", wifi connection hangs
10. after opening kwallet, wifi connects correctly

% journalctl -b | grep kwallet
cze 20 08:26:50 bazyliszek sddm-helper[1655]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
cze 20 08:26:50 bazyliszek sddm-helper[1655]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
cze 20 08:26:50 bazyliszek sddm-helper[1655]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session
cze 20 08:26:50 bazyliszek sddm-helper[1688]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
cze 20 08:26:54 bazyliszek dbus-daemon[1704]: [session uid=1000 pid=1704] Activating service name='org.kde.kwalletd5' requested by ':1.9' (uid=1000 pid=1758 comm="kded5 " label="unconfined")
cze 20 08:26:54 bazyliszek dbus-daemon[1704]: [session uid=1000 pid=1704] Successfully activated service 'org.kde.kwalletd5'
cze 20 08:26:54 bazyliszek org.kde.kwalletd5[1806]: Application ' "kded5" ' using kwallet without parent window!
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: Checking for pam module
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: Got pam-login param
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: Waiting for hash on 7-
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: waitingForEnvironment on: 3
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: client connected
cze 20 08:26:56 bazyliszek sddm[1689]: kwalletd5: client disconnected

---

Operating System: Kubuntu 20.04
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.4.0-37-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8300H CPU @ 2.30GHz
Memory: 15,5 GiB of RAM

libpam-kwallet5 4:5.18.4.1-0ubuntu1
Comment 29 Metal450 2020-07-14 01:30:05 UTC
I'm on KDE Plasma 5.18.5, KDE Frameworks 5.68.0, and I experience this only intermittently.  The behavior is identical to what's described here, but it only happens maybe 1 out of 5 reboots.  4 out of 5 times it unlocks properly.  There doesn't seem to be any rhyme or reason to why/when.
Comment 30 Richard Ullger 2020-08-10 09:15:05 UTC
This is fixed in the current version,

Operating System: Arch Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.7.12-arch1-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5 CPU M 430 @ 2.27GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics

...and prior versions. See Comments 26 & 27.
Comment 31 Cocoa 2022-06-20 01:06:15 UTC
I am experiencing same issue in KDE 5.25 on KDE Neon. Here are my system specs -

Operating System: KDE neon 5.25
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4
Kernel Version: 5.13.0-51-generic (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 11.0 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: LENOVO
Product Name: 81HN
System Version: Lenovo V130-15IKB
Comment 32 Nate Graham 2022-06-21 16:14:19 UTC
Can you confirm that:
1. your wallet is named "kdewallet"
2. its password is *identical* to the password for your user account
3. you don't have auto-login turned on
Comment 33 Cocoa 2022-06-21 16:17:51 UTC
Hello. Yes, no autologin, password identical to the wallet one, and the wallet does seem to be named "kdewallet" (https://ibb.co/zhNDWvy)
Comment 34 Nate Graham 2022-06-21 16:34:56 UTC
Does it start working if you temporarily disable systemd boot by running `kwriteconfig5 --file startkderc --group General --key systemdBoot false` in a terminal window, and then reboot?