Bug 415640 - Amarok's files sort function not working and crashing
Summary: Amarok's files sort function not working and crashing
Status: RESOLVED DUPLICATE of bug 415642
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: kf5
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-12-28 13:36 UTC by kde
Modified: 2019-12-28 13:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2019-12-28 13:36:43 UTC
Application: amarok (2.9.70)

Qt Version: 5.13.1
Frameworks Version: 5.65.0
Operating System: Linux 5.3.12-2-default x86_64
Distribution: openSUSE Tumbleweed

-- Information about the crash:
- What I was doing when the application crashed:

I right-clicked on an album to automatically rename and sort the files. First window opened, clicked on "move without converting". Second window opened too small, buttons "Ok" and "cancel" would not react. Closed this window (files not being renamed or moved) and Amarok crashed.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#6  0x00007f4cc4504960 in QQmlData::signalHasEndpoint (this=0x55cb9e70f4c0, index=7) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:370
#7  QQmlData::isSignalConnected (index=7, d=0x55cb9e70f4c0) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/src/qml/qml/qqmlengine.cpp:904
#8  QQmlData::isSignalConnected (d=0x55cb9e70f4c0, index=7) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/src/qml/qml/qqmlengine.cpp:899
#9  0x00007f4cc7f31d9a in QObjectPrivate::isDeclarativeSignalConnected (signal_index=7, this=<optimized out>) at kernel/qobject_p.h:110
[...]
#11 0x00007f4cc7f32638 in QtPrivate::QSlotObjectBase::call (a=0x7ffd321b1f90, r=0x55cb9e75d2d0, this=0x55cb9e707f00) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394


Reported using DrKonqi
Comment 1 kde 2019-12-28 13:47:13 UTC
Sorry, DrKonqi reported that my report could not be send so I created a new one manually.

*** This bug has been marked as a duplicate of bug 415642 ***