Bug 415633 - tagged splits not recognised in list of tagged transactions
Summary: tagged splits not recognised in list of tagged transactions
Status: RESOLVED DUPLICATE of bug 412429
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 5.0.7
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-28 06:23 UTC by Gekko
Modified: 2019-12-28 08:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gekko 2019-12-28 06:23:01 UTC
When creating a tagged split in a transaction, the tagged part of the transaction does not appear in the list of tagged transactions in the tag tab.


STEPS TO REPRODUCE
1. create a transaction with at least one split.
2. apply a tag to the split
3. do not apply the tag at the transaction level
4. go to the 'tags' tab and view the transactions associated with that tag

OBSERVED RESULT
The transaction entered above does not show up in the list of transactions with that tag. It shows up if the tag is applied at the transaction level rather than the split.


EXPECTED RESULT
I would expect to see the split in the transaction list on the tag tab as the tag is applied to it even though it does not apply to the whole transaction. At the very least I would expect to see the transaction with an indicator that a component of that transaction contains the tag.


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Arch Linux 5.4.6-arch3-1
(available in About System)
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.65.0
Qt Version: 5.14.0

ADDITIONAL INFORMATION
Comment 1 Thomas Baumgart 2019-12-28 08:53:29 UTC

*** This bug has been marked as a duplicate of bug 412429 ***