Bug 415473 - Using 'Save As' removes extended file attributes.
Summary: Using 'Save As' removes extended file attributes.
Status: RESOLVED DUPLICATE of bug 116617
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 19.12.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-23 09:25 UTC by Thomas Marshall
Modified: 2020-01-01 23:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Marshall 2019-12-23 09:25:17 UTC
SUMMARY

If one uses the 'Save As' feature, xattrs are obliterated on the new file.

STEPS TO REPRODUCE
1. Open an image that has some xattrs (tags, rating, comment)
2. Click Save As, and save under a different name
3. Open the new file or use attr -l to observe that the xattrs are gone.

OBSERVED RESULT

The xattrs are deleted.

EXPECTED RESULT

The xattrs should be preserved.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.17
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.65.0
Qt Version: 5.13.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2020-01-01 23:45:37 UTC
Same root cause as Bug 116617.

*** This bug has been marked as a duplicate of bug 116617 ***