Bug 415356 - plasma crashes on startup
Summary: plasma crashes on startup
Status: RESOLVED DUPLICATE of bug 415650
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.17.4
Platform: Archlinux Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
: 415122 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-19 14:33 UTC by Niklas Moran
Modified: 2020-01-09 00:40 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.77 KB, text/plain)
2019-12-20 16:51 UTC, Niklas Moran
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niklas Moran 2019-12-19 14:33:19 UTC
Application: plasmashell (5.17.4)

Qt Version: 5.14.0
Frameworks Version: 5.65.0
Operating System: Linux 5.4.5-zen1-1-zen x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Booted into plasma. Thunderbird started, as did yakuake, pgpadmin and other applications.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7ae8f31cc0 (LWP 666))]

Thread 11 (Thread 0x7f7ab3d6e700 (LWP 1321)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7aed5bbcc4 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f7aed5bbda2 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f7aef32718b in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f7aef32741b in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 10 (Thread 0x7f7ac5ae7700 (LWP 1157)):
#0  0x00007f7aed22d9ef in poll () at /usr/lib/libc.so.6
#1  0x00007f7aeba97120 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f7aeba971f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f7aed7e8cdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f7aed78f39c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f7aed5b4e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f7aef261e9b in  () at /usr/lib/libQt5Quick.so.5
#7  0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f7ac6403700 (LWP 1131)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7aed5bbcc4 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f7aed5bbda2 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f7aef32718b in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f7aef32741b in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f7ad632f700 (LWP 781)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7ad7828d0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f7ad7828908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f7ad6b30700 (LWP 780)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7ad7828d0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f7ad7828908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f7ad7331700 (LWP 779)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7ad7828d0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f7ad7828908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f7ae4989700 (LWP 778)):
#0  0x00007f7aec9fcc45 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f7ad7828d0c in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f7ad7828908 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f7ae63e4700 (LWP 756)):
#0  0x00007ffe3d3f86bb in  ()
#1  0x00007ffe3d3f8908 in clock_gettime ()
#2  0x00007f7aed24556b in clock_gettime () at /usr/lib/libc.so.6
#3  0x00007f7aed7e85c2 in  () at /usr/lib/libQt5Core.so.5
#4  0x00007f7aed7e6eaa in QTimerInfoList::updateCurrentTime() () at /usr/lib/libQt5Core.so.5
#5  0x00007f7aed7e7476 in QTimerInfoList::timerWait(timespec&) () at /usr/lib/libQt5Core.so.5
#6  0x00007f7aed7e8a1f in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f7aeba96a00 in g_main_context_prepare () at /usr/lib/libglib-2.0.so.0
#8  0x00007f7aeba97046 in  () at /usr/lib/libglib-2.0.so.0
#9  0x00007f7aeba971f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#10 0x00007f7aed7e8cdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#11 0x00007f7aed78f39c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#12 0x00007f7aed5b4e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#13 0x00007f7aeefbe479 in  () at /usr/lib/libQt5Qml.so.5
#14 0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#16 0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f7ae7650700 (LWP 707)):
#0  0x00007f7aed22d9ef in poll () at /usr/lib/libc.so.6
#1  0x00007f7aeba97120 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f7aeba971f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f7aed7e8cdc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f7aed78f39c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f7aed5b4e62 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f7aee13db28 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f7ae844a700 (LWP 700)):
#0  0x00007f7aed22d9ef in poll () at /usr/lib/libc.so.6
#1  0x00007f7aef76a630 in  () at /usr/lib/libxcb.so.1
#2  0x00007f7aef76c2db in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f7ae8dd9a01 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f7aed5b5fd6 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f7aec9f64cf in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f7aed2382d3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f7ae8f31cc0 (LWP 666)):
[KCrash Handler]
#6  0x00007f7ac46847b6 in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#7  0x00007f7ac4680e21 in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#8  0x00007f7ac46817eb in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#9  0x00007f7aeeef8809 in QQmlVMEMetaObject::metaCall(QObject*, QMetaObject::Call, int, void**) () at /usr/lib/libQt5Qml.so.5
#10 0x00007f7aeee2d08c in  () at /usr/lib/libQt5Qml.so.5
#11 0x00007f7aeee2e60e in QV4::QObjectWrapper::virtualResolveLookupGetter(QV4::Object const*, QV4::ExecutionEngine*, QV4::Lookup*) () at /usr/lib/libQt5Qml.so.5
#12 0x00007f7aeee4d027 in  () at /usr/lib/libQt5Qml.so.5
#13 0x00007f7aeee5230f in  () at /usr/lib/libQt5Qml.so.5
#14 0x00007f7aeede3340 in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () at /usr/lib/libQt5Qml.so.5
#15 0x00007f7aeef74260 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () at /usr/lib/libQt5Qml.so.5
#16 0x00007f7aeef7a020 in QQmlBinding::evaluate(bool*) () at /usr/lib/libQt5Qml.so.5
#17 0x00007f7aeef7ecca in  () at /usr/lib/libQt5Qml.so.5
#18 0x00007f7aeef7b31c in QQmlBinding::update(QFlags<QQmlPropertyData::WriteFlag>) () at /usr/lib/libQt5Qml.so.5
#19 0x00007f7aeef8ccde in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () at /usr/lib/libQt5Qml.so.5
#20 0x00007f7aeef15b0b in  () at /usr/lib/libQt5Qml.so.5
#21 0x00007f7aeef16053 in QQmlEnginePrivate::incubate(QQmlIncubator&, QQmlContextData*) () at /usr/lib/libQt5Qml.so.5
#22 0x00007f7aeef129e2 in QQmlComponent::create(QQmlIncubator&, QQmlContext*, QQmlContext*) () at /usr/lib/libQt5Qml.so.5
#23 0x00007f7aef6745ac in KDeclarative::QmlObject::createObjectFromComponent(QQmlComponent*, QQmlContext*, QHash<QString, QVariant> const&) () at /usr/lib/libKF5Declarative.so.5
#24 0x00007f7aefb61c9f in  () at /usr/lib/libKF5PlasmaQuick.so.5
#25 0x00007f7aefb61eab in  () at /usr/lib/libKF5PlasmaQuick.so.5
#26 0x00007f7aefb623e2 in  () at /usr/lib/libKF5PlasmaQuick.so.5
#27 0x00007f7aed7ca143 in  () at /usr/lib/libQt5Core.so.5
#28 0x00007f7aed7be055 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#29 0x00007f7aee3b1472 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#30 0x00007f7aee3bac89 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#31 0x00007f7aed790832 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#32 0x00007f7aed7e805d in QTimerInfoList::activateTimers() () at /usr/lib/libQt5Core.so.5
#33 0x00007f7aed7e892a in  () at /usr/lib/libQt5Core.so.5
#34 0x00007f7aeba9539e in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#35 0x00007f7aeba971b1 in  () at /usr/lib/libglib-2.0.so.0
#36 0x00007f7aeba971f1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#37 0x00007f7aed7e8cc0 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#38 0x00007f7aed78f39c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#39 0x00007f7aed7973a6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#40 0x00005564bbf30dc9 in  ()
#41 0x00007f7aed160153 in __libc_start_main () at /usr/lib/libc.so.6
#42 0x00005564bbf3122e in _start ()
[Inferior 1 (process 666) detached]

The reporter indicates this bug may be a duplicate of or related to bug 415122.

Possible duplicates by query: bug 415351, bug 415339, bug 415335, bug 415316, bug 415304.

Reported using DrKonqi
Comment 1 Niklas Moran 2019-12-20 16:51:30 UTC
Created attachment 124621 [details]
New crash information added by DrKonqi

plasmashell (5.17.4) using Qt 5.14.0

- What I was doing when the application crashed:

Just started up. firefox-nightly starts on startup and it was restoring previous session even though I had closed firefox and a bunch of programs. That was probably because I restarted with shutdown -r now.

-- Backtrace (Reduced):
#6  0x00007f788dc227b6 in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#7  0x00007f788dc1ee21 in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#8  0x00007f788dc1f7eb in  () at /usr/lib/qt/qml/org/kde/plasma/calendar/libcalendarplugin.so
#9  0x00007f78b8089809 in QQmlVMEMetaObject::metaCall(QObject*, QMetaObject::Call, int, void**) () at /usr/lib/libQt5Qml.so.5
#10 0x00007f78b7fbe08c in  () at /usr/lib/libQt5Qml.so.5
Comment 2 Christoph Feck 2019-12-29 08:09:16 UTC
Did you login with your root account?
Comment 3 David Edmundson 2020-01-09 00:39:52 UTC
*** Bug 415122 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2020-01-09 00:40:36 UTC

*** This bug has been marked as a duplicate of bug 415650 ***