Bug 415109 - Latte Dock crash when opening settings
Summary: Latte Dock crash when opening settings
Status: RESOLVED WORKSFORME
Alias: None
Product: lattedock
Classification: Plasma
Component: application (show other bugs)
Version: 0.9.3
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michail Vourlakos
URL:
Keywords: drkonqi
: 415110 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-12 20:39 UTC by DarnedDev
Modified: 2020-05-06 11:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.53 KB, text/plain)
2019-12-12 20:40 UTC, DarnedDev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DarnedDev 2019-12-12 20:39:16 UTC
Application: latte-dock (0.9.3)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-24-generic x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- Unusual behavior I noticed:
The dock froze and crashed when displaying the settings panel. Relaunching the app is impossible without a restart, after one - the crash repeats

The crash can be reproduced every time.

-- Backtrace:
Application: Latte Dock (latte-dock), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8291a83c80 (LWP 2055))]

Thread 5 (Thread 0x7f8277815700 (LWP 2071)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x559923bb2c24) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x559923bb2bd0, cond=0x559923bb2bf8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x559923bb2bf8, mutex=0x559923bb2bd0) at pthread_cond_wait.c:638
#3  0x00007f829544fdef in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f829544fee1 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f82971547b9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f8297154a1a in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f8295449cc2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f829445c669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007f8294f65323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f8283fff700 (LWP 2066)):
#0  0x00007f8293a7c58d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f8293a7dbac in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8293a7eefb in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8293a7f96b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8293a7fb73 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f82956686c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f829560f63b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f8295448a75 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f8296df9319 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f8295449cc2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f829445c669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#11 0x00007f8294f65323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f828bcbe700 (LWP 2059)):
#0  __GI___libc_read (nbytes=16, buf=0x7f828bcbdb60, fd=7) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=7, buf=0x7f828bcbdb60, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f8293ac763f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8293a7f58e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8293a7f9e2 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8293a7fb73 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f82956686c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f829560f63b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f8295448a75 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f8295940efa in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#10 0x00007f8295449cc2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f829445c669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#12 0x00007f8294f65323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f8290beb700 (LWP 2057)):
#0  0x00007f8294f58c2f in __GI___poll (fds=0x7f8290beaca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f8297563917 in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f829756553a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f82913d3288 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f8295449cc2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f829445c669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007f8294f65323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f8291a83c80 (LWP 2055)):
[KCrash Handler]
#5  __memmove_sse2_unaligned_erms () at ../sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S:353
#6  0x00007f82960a7cd3 in KSharedDataCache::insert(QString const&, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#7  0x00007f8297502085 in ?? () from /lib/x86_64-linux-gnu/libKF5Plasma.so.5
#8  0x00007f829563c5c8 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f829564966b in QTimer::timeout(QTimer::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f829563ce55 in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f8296301a86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007f829630ae00 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007f8295610a9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f8295667a00 in QTimerInfoList::activateTimers() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f8295668324 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f8293a7f84d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f8293a7fad0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f8293a7fb73 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f82956686a5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f829560f63b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f82956173a6 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00005599213a3b2e in main ()
[Inferior 1 (process 2055) detached]

Reported using DrKonqi
Comment 1 DarnedDev 2019-12-12 20:40:57 UTC
Created attachment 124455 [details]
New crash information added by DrKonqi

latte-dock (0.9.3) using Qt 5.12.4

This is a secondary report and traceback that occured after the main settings crash

-- Backtrace (Reduced):
#5  __memmove_sse2_unaligned_erms () at ../sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S:369
#6  0x00007f10d8993cd3 in KSharedDataCache::insert(QString const&, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
[...]
#9  0x00007f10d7f3566b in QTimer::timeout(QTimer::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f10d7f28e55 in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f10d8beda86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
Comment 2 Myriam Schweingruber 2020-01-01 17:10:05 UTC
*** Bug 415110 has been marked as a duplicate of this bug. ***
Comment 3 Michail Vourlakos 2020-01-01 19:49:01 UTC
this crash does not point to any latte dock... in any case because this is Kubuntu, first thing to try for crashes:

1. Close Latte
2. run in terminal "latte-dock --cc"
3. Does the crash still occur?
Comment 4 Michail Vourlakos 2020-01-01 19:49:55 UTC
4. If it does not you should follow: https://userbase.kde.org/LatteDock/HowToReportCrashes
Comment 5 Michail Vourlakos 2020-04-21 10:01:03 UTC
Points upstream but better crash report is needed
Comment 6 Bug Janitor Service 2020-05-06 04:33:12 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 DarnedDev 2020-05-06 11:50:21 UTC
In an attempt to get a better report I tried to replicate the crash on the latest version of Latte Dock (0.9.11) and couldn't get it to happen. Looks like the issue was fixed in one of the updates since I filed this report, sorry for wasting people's time.