Bug 415073 - Battery should ideally turn into a Brightness or Power icon if no batteries are on the device
Summary: Battery should ideally turn into a Brightness or Power icon if no batteries a...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Battery Monitor (show other bugs)
Version: 5.17.4
Platform: Neon Packages Linux
: NOR minor
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-11 22:22 UTC by The Feren OS Dev
Modified: 2022-01-15 11:38 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description The Feren OS Dev 2019-12-11 22:22:03 UTC
SUMMARY
When running off a machine that is only powered by a plugged in power source (not a laptop or tablet) the Battery icon remains in the system tray as a redundant item in the tray by default.

STEPS TO REPRODUCE
1. Boot into Neon on a no-batteries machine
2. Check the System Tray

OBSERVED RESULT
There is a no batteries detected icon in there and its only use is toggling power management

EXPECTED RESULT
The icon would change to one of the following:
- Brightness icon if brightness can be changed still (Cinnamon)
- Power Symbol such as a lightning bolt if only toggling power management is available

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: KDE neon
(available in About System)
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2

ADDITIONAL INFORMATION
Having a no batteries icon on a computer that is only powered by a plug is pointless and just feels out of place.
Comment 1 The Feren OS Dev 2019-12-11 22:24:08 UTC
Slight bonus suggestion: Add an option in the Battery Plasmoid's settings to not hide the Plasmoid in the tray overflow menu when the battery is fully charged.
Comment 3 Nate Graham 2022-01-04 17:37:59 UTC
Git commit f9e39815dcf64c6b425737b51257b46cd400d5db by Nate Graham, on behalf of Aleix Pol Gonzalez.
Committed on 04/01/2022 at 17:37.
Pushed by ngraham into branch 'master'.

applets/batterymonitor: Improve for desktop systems

As it was so far, it looked like the system was malfunctioning because
we were showing a battery with a big fat red mark. If there's no battery
we can show the default icon.

As for the name, we only say "battery and brightness" when there's
both of them. Otherwise we show either title.

If neither batteries nor brightness are available, we mark the applet as
passive so people can at least still access the power management blocking
checkbox which lives here.
FIXED-IN: 5.24

M  +18   -5    applets/batterymonitor/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/f9e39815dcf64c6b425737b51257b46cd400d5db
Comment 4 Patrick Silva 2022-01-13 21:50:11 UTC
The icon is no longer monochrome on Plasma 5.24 beta, it's green instead.
Is this intentional?
I'm using a desktop computer.
Comment 5 Nate Graham 2022-01-13 23:17:31 UTC
Hmm, that should have been fixed by https://invent.kde.org/plasma/plasma-workspace/-/commit/471cc3745b3a51a8b427fc1b44a22de228cbd945

Either way can you open a new bug report for it?
Comment 6 Patrick Silva 2022-01-15 11:38:09 UTC
(In reply to Nate Graham from comment #5)
> Hmm, that should have been fixed by
> https://invent.kde.org/plasma/plasma-workspace/-/commit/
> 471cc3745b3a51a8b427fc1b44a22de228cbd945
> 
> Either way can you open a new bug report for it?
Reported as bug 448520