Bug 415051 - KMail can't show ASCII-emails larger than 1.2 MiB
Summary: KMail can't show ASCII-emails larger than 1.2 MiB
Status: RESOLVED DUPLICATE of bug 387061
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.11.3
Platform: Fedora RPMs Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-11 14:26 UTC by Attila
Modified: 2020-01-10 10:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Attila 2019-12-11 14:26:54 UTC
SUMMARY
If I click on an ASCII-email, which is larger than 1.2 MiB to read it, it will not be shown. There is neither a warning nor an interaction with the user that this email can't be displayed.
It was in prior versions of kmail no problem to show large ASCII-emails.

STEPS TO REPRODUCE
1. Launch kmail
2. Try to read an ASCII-email larger than 1.2 MiB
3. 

OBSERVED RESULT
Kmail doesn't give the user any warning and it dosn't show the content of the email.


EXPECTED RESULT
Kmail should show the email like it has done in earlier versions.

SOFTWARE/OS VERSIONS

Operating System: Fedora 31
KDE Plasma Version: 5.16.5
KDE Frameworks Version: 5.64.0
Qt Version: 5.12.5
Kernel Version: 5.3.15-300.fc31.x86_64
OS Type: 64-bit


ADDITIONAL INFORMATION
My workaround is to save the email to a file and open it by Kwrite.
By the way KWrite can even open emails saved to a file larger than 25 MiB.
Comment 1 Christoph Feck 2020-01-10 10:03:45 UTC

*** This bug has been marked as a duplicate of bug 387061 ***