Bug 414885 - akonadi crash after reading a new mail
Summary: akonadi crash after reading a new mail
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.3
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-12-06 08:04 UTC by Bruno Friedmann
Modified: 2020-02-18 13:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (98.98 KB, patch)
2019-12-06 08:04 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2019-12-06 08:04:50 UTC
Application: akonadiserver (5.12.3)

Qt Version: 5.13.1
Frameworks Version: 5.64.0
Operating System: Linux 5.3.12-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: After having moved several mail to trash, junk and read others in multiple folders, I've jump to the gmail imap account and read one mail and want to trash the second new.
Here what I've found in system log
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "searchUpdate-1575619077" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search update for collection "OpenInvitations" ( 457 ) finished: all results:  0 , removed results: 0
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "searchUpdate-1575619077"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "searchUpdate-1575619077" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search update for collection "DeclinedInvitations" ( 458 ) finished: all results:  0 , removed results: 0
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "searchUpdate-1575619077"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "searchUpdate-1575619077" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search update for collection "Last Search" ( 492 ) finished: all results:  0 , removed results: 0
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
kmail[24391]: QFont::setPixelSize: Pixel size <= 0 (0)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
kmail[24391]: qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 9570, resource id: 106954806, major code: 130 (Unknown), minor code: 3
kmail[24391]: qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 9590, resource id: 106954806, major code: 130 (Unknown), minor code: 3
kmail[24391]: qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 9593, resource id: 106954806, major code: 130 (Unknown), minor code: 3
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Executing search "kmail2-48271-SearchSession"
akonadiserver[3832]: org.kde.pim.akonadiserver.search: Search  "kmail2-48271-SearchSession" done (without remote search)
akonadiserver[3832]: QIODevice::write (QLocalSocket): device not open
akonadiserver[3832]: Qt has caught an exception thrown from an event handler. Throwing
                     exceptions from an event handler is not supported in Qt.
                     You must not let any exception whatsoever propagate through Qt code.
                     If that is not possible, in Qt 5 you must at least reimplement
                     QCoreApplication::notify() and catch all exceptions there.
kdeinit5[1943]: Registering ":1.272/StatusNotifierItem" to system tray
plasmashell[1989]: QQuickItem::stackAfter: Cannot stack StatusNotifierItem_QMLTYPE_309(0x55a8625c89d0, parent=0x55a8604791b0, geometry=0,0 0x0) after StatusNotifierItem_QMLTYPE_309(0x55a86232f3c0), which must be a sibling
kwin_x11[1982]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12946, resource id: 35651953, major code: 15 (QueryTree), minor code: 0
kdeinit5[1943]: Service  ":1.272" unregistered

The crash can be reproduced every time.

-- Backtrace (Reduced):
#11 0x00007ff803435ea3 in qTerminate () at global/qglobal.cpp:3252
#12 0x00007ff803437900 in QThreadPrivate::start (arg=0x55ba90b97930) at thread/qthread_unix.cpp:372
[...]


The reporter indicates this bug may be a duplicate of or related to bug 414700.

Possible duplicates by query: bug 414843, bug 414838, bug 414794, bug 414700, bug 414574.

Reported using DrKonqi
Comment 1 Bruno Friedmann 2019-12-06 08:04:50 UTC
Created attachment 124332 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Cyril Rossi 2020-02-18 13:06:06 UTC
Git commit c7c190488e46f49d85ab8695f32008eb6f352ad8 by Cyril Rossi.
Committed on 18/02/2020 at 13:04.
Pushed by crossi into branch 'master'.

Breeze widgetStyle value is Breeze

Summary: BUG: 414885

Reviewers: ervin, bport, meven, mart, davidedmundson

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D27407

M  +1    -1    lookandfeel/contents/defaults

https://commits.kde.org/plasma-workspace/c7c190488e46f49d85ab8695f32008eb6f352ad8