Bug 414659 - vex amd64->IR: unhandled instruction bytes: 0x48 0xCF 0xF 0x1F 0x0 0xFF 0xD2 0xCC 0x90 0x55
Summary: vex amd64->IR: unhandled instruction bytes: 0x48 0xCF 0xF 0x1F 0x0 0xFF 0xD2 ...
Status: RESOLVED DUPLICATE of bug 400538
Alias: None
Product: valgrind
Classification: Developer tools
Component: general (show other bugs)
Version: 3.13.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-29 16:55 UTC by Eric Knaak
Modified: 2019-11-29 18:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Log after running autonauts in wine in valgrind (30.02 KB, text/plain)
2019-11-29 16:55 UTC, Eric Knaak
Details
Hard_info report (65.00 KB, text/html)
2019-11-29 17:30 UTC, Eric Knaak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Knaak 2019-11-29 16:55:27 UTC
Created attachment 124183 [details]
Log after running autonauts in wine in valgrind

SUMMARY

Wine version doesn't seem to mater. Most recently I ran using wine 4.20

STEPS TO REPRODUCE
1. Install autonauts
2. tell valgrind to run autonauts.
3. get this error
==21781== valgrind: Unrecognised instruction at address 0x7bcb6b83.
==21781==    at 0x7BCB6B83: ??? (in /opt/wine-devel/lib64/wine/ntdll.dll.so)

OBSERVED RESULT
==21781== valgrind: Unrecognised instruction at address 0x7bcb6b83.
==21781==    at 0x7BCB6B83: ??? (in /opt/wine-devel/lib64/wine/ntdll.dll.so)

EXPECTED RESULT
Autonauts to run normally and not crash with an error

SOFTWARE/OS VERSIONS
Ubuntu 18.04
Valgrind 3.13.0
wine 4.20


 

ADDITIONAL INFORMATION
Attempted with valgrind 3.15 But I don't know how to compile it correctly.
I'll add more info if I can get valgrind 3.15 running.
Comment 1 Eric Knaak 2019-11-29 17:20:49 UTC
steam for linux version: Built: Nov 20 2019, at 01:49:33
Comment 3 Eric Knaak 2019-11-29 17:30:43 UTC
Created attachment 124184 [details]
Hard_info report
Comment 4 Tom Hughes 2019-11-29 17:36:33 UTC
Please give us the full error - valgrind should have reported what instruction it couldn't decode in detail before the stack trace.
Comment 5 Eric Knaak 2019-11-29 17:42:58 UTC
tried building the 32 bit binary to get 3.15 to run, but "/usr/bin/ld: i386:x86-64 architecture of input file `valgrind-m_debuglog.o' is incompatible with i386 output" instead. I'll look for help so I can see if this issue is in the 3.15 version.
Comment 6 Eric Knaak 2019-11-29 17:47:24 UTC
(In reply to Tom Hughes from comment #4)
> Please give us the full error - valgrind should have reported what
> instruction it couldn't decode in detail before the stack trace.

The full error should be in the log file attached. Is it not in there?
"Log after running autonauts in wine in valgrind"
Where can I find the full error. is it in a log file somewhere?
Comment 7 Tom Hughes 2019-11-29 17:54:02 UTC
Sorry I missed that. Here are the important details:

vex amd64->IR: unhandled instruction bytes: 0x48 0xCF 0xF 0x1F 0x0 0xFF 0xD2 0xCC 0x90 0x55
vex amd64->IR:   REX=1 REX.W=1 REX.R=0 REX.X=0 REX.B=0
vex amd64->IR:   VEX=0 VEX.L=0 VEX.nVVVV=0x0 ESC=NONE
vex amd64->IR:   PFX.66=0 PFX.F2=0 PFX.F3=0
==21781== valgrind: Unrecognised instruction at address 0x7bcb6b83.
Comment 8 Tom Hughes 2019-11-29 17:57:42 UTC
So that is IRET which is not currently supported in 64 bit mode.

We already have a bug covering this so I'm going to close this as a duplicate.

*** This bug has been marked as a duplicate of bug 253657 ***
Comment 9 Julian Seward 2019-11-29 18:30:54 UTC
Hmm, IRETQ got fixed recently, bug 400538, exactly for the purposes
of running Wine in 64-bit mode.  It's in the trunk:

git clone git://sourceware.org/git/valgrind.git

But maybe I misunderstand?
Comment 10 Tom Hughes 2019-11-29 18:59:27 UTC
Ah I had a feeling it has been fixed recently but I missed that.

The user here is running 3.13 so won't have the fix but I'll update the duplicate.

*** This bug has been marked as a duplicate of bug 400538 ***