Bug 414567 - system settings should not show apply/discard prompt on close after a task switcher from kde store to be installed
Summary: system settings should not show apply/discard prompt on close after a task sw...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: tabbox (show other bugs)
Version: 5.17.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Cyril Rossi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-27 12:06 UTC by Patrick Silva
Modified: 2020-04-01 09:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.19


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-11-27 12:06:56 UTC
STEPS TO REPRODUCE
1. open system settings > window management > task switcher
2. click on "Get new task switchers..." button
3. install any task switcher (I installed Thumbnail Grid and Scaling Switcher)
4. try to close system settings

OBSERVED RESULT
system settings shows apply/discard prompt

EXPECTED RESULT
system settings should not show apply/discard prompt because no setting was changed

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Comment 1 Cyril Rossi 2020-03-03 08:54:54 UTC
Can reproduce as well.

This patch should solve the issue : https://phabricator.kde.org/D27784
Comment 2 Cyril Rossi 2020-04-01 09:09:49 UTC
Git commit 51a1e06dfc1fb8832c89d5f8a4abf24ff56bb32c by Cyril Rossi.
Committed on 01/04/2020 at 09:01.
Pushed by crossi into branch 'master'.

KCM KWinTabBox manage KCModule states

Summary:
Following D27323, manage KCModule states for reinitialize/defaults/apply

Also, this should solve :
Related: bug 387160
FIXED-IN: 5.19

Reviewers: #kwin, ervin, bport, meven, zzag

Reviewed By: #kwin, ervin, meven, zzag

Subscribers: kwin

Tags: #kwin

Differential Revision: https://phabricator.kde.org/D27784

M  +1    -0    kcmkwin/kwintabbox/CMakeLists.txt
A  +353  -0    kcmkwin/kwintabbox/kwintabboxconfigform.cpp     [License: GPL (v2)]
A  +122  -0    kcmkwin/kwintabbox/kwintabboxconfigform.h     [License: GPL (v2)]
M  +163  -254  kcmkwin/kwintabbox/main.cpp
M  +16   -28   kcmkwin/kwintabbox/main.h
M  +5    -5    kcmkwin/kwintabbox/main.ui

https://commits.kde.org/kwin/51a1e06dfc1fb8832c89d5f8a4abf24ff56bb32c