Bug 414533 - cannot install obs studio via Spectacle
Summary: cannot install obs studio via Spectacle
Status: RESOLVED FIXED
Alias: None
Product: frameworks-knewstuff
Classification: Unclassified
Component: general (show other bugs)
Version: 5.91.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-26 11:52 UTC by Patrick Silva
Modified: 2022-02-14 16:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.92


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-11-26 11:52:09 UTC
STEPS TO REPRODUCE
1. open Spectacle by pressing printscreen key
2. click on "Tools" button
3. hover over record screen > more > obs studio
4. click on "Install"

OBSERVED RESULT
Discover opens and shows "Couldn't open appstream://com.obsproject.studio.desktop"
error

EXPECTED RESULT
Discover shows the description page of obs studio

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.17.80
KDE Frameworks Version: 5.65.0
Qt Version: 5.13.2
Comment 1 Aleix Pol 2019-11-29 13:55:36 UTC
That's an issue because obs on Neon is too old.

It will work fine if you have it available from other sources or you have a distro that contains up-to-date information about apps.
Comment 2 Patrick Silva 2022-02-10 13:03:03 UTC
Discover does also not find OBS Studio from flathub on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 3 Bug Janitor Service 2022-02-11 16:55:31 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/knewstuff/-/merge_requests/169
Comment 4 Nate Graham 2022-02-14 16:06:52 UTC
Git commit 8727f8e908cdadf6edbf77cd55f514540fba2366 by Nate Graham, on behalf of Aleix Pol.
Committed on 14/02/2022 at 16:06.
Pushed by ngraham into branch 'master'.

kmoretools: Fix OBS appstream id

M  +1    -1    src/kmoretools/kmoretoolspresets.cpp

https://invent.kde.org/frameworks/knewstuff/commit/8727f8e908cdadf6edbf77cd55f514540fba2366