Bug 414475 - cannot login to invent.kde.org using gitlab account
Summary: cannot login to invent.kde.org using gitlab account
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-24 21:39 UTC by Uwe Stöhr
Modified: 2019-11-30 00:55 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of the 2 login methods (5.38 KB, image/png)
2019-11-24 22:31 UTC, Uwe Stöhr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Stöhr 2019-11-24 21:39:14 UTC
I want to contribute to the KDE project LabPlot. It moved recently to Gitlab. Therefore I created a Gitlab account and con log in successfully.

But I cannot login to
https://invent.kde.org/users/sign_in
On the login site I can switch between KDE identity and standard login. I choose standard login to login using my Gitlab account.
But this doesn't work.

When using the credentials I used to create this bug report to login via the KDE identity account, it also doesn't work.

So I see 2 issues:
- login must be possible using a normal GitLab account
- login to https://bugs.kde.org should work for all ***https://***.kde.org pages
Comment 1 carl 2019-11-24 21:53:12 UTC
Hello Uwe,

the issue is that you need a KDE Identity to log into invent.kde.org.

KDE Identity is used for all the KDE service but bugs.kde.org.

You can create a new account here: https://identity.kde.org/

Cheers,

Carl
Comment 2 Uwe Stöhr 2019-11-24 22:30:44 UTC
> the issue is that you need a KDE Identity to log into invent.kde.org.

This does not solve the issue:
https://invent.kde.org/users/sign_in
allows you to login in 2 ways, one with the KDE identity and one with the GitLab identity, see the attached screenshot. So I want to login using thee GitLab account. if this is not possible, please remove this from the login page or at least explain the users what "Standard" login means on the login page.
Comment 3 Uwe Stöhr 2019-11-24 22:31:15 UTC
Created attachment 124105 [details]
screenshot of the 2 login methods
Comment 4 Nicolás Alvarez 2019-11-29 22:22:41 UTC
We have now removed the "standard login" option. Thanks for your report!
Comment 5 Uwe Stöhr 2019-11-30 00:46:53 UTC
Thanks Nicolás.(In reply to Nicolás Alvarez from comment #4)
> We have now removed the "standard login" option.

Thanks Nicolás.

Unfortunately the KDE identity does not yet support the same login features as GitLab. I opened therefore bug 414673
Comment 6 Nicolás Alvarez 2019-11-30 00:55:52 UTC
KDE Identity as a whole has lots of flaws and we plan to replace it.