Bug 414337 - I'm no longer able to apply night color settings
Summary: I'm no longer able to apply night color settings
Status: RESOLVED DUPLICATE of bug 411584
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_nightcolor (show other bugs)
Version: 5.17.3
Platform: Neon Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-20 18:49 UTC by Komorebi
Modified: 2019-12-09 09:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Komorebi 2019-11-20 18:49:20 UTC
Since the feature was added for X.org sessions, I've enabled it when received 5.17.0 update. 
Today I've found that changing any night color settings doesn't active an "Apply" button, so I'm no longer able to apply any changes I've made. I got stuck on "Times" operation mode, and changing any values (including sunrise/sunset, operation mode, temperature, activate checkbox itself) does actually nothing. 


STEPS TO REPRODUCE
1. Open settings
2. Go to night color
3. Change any value

OBSERVED RESULT
Apply button is grayed out

EXPECTED RESULT
Apply to become active 

Operating System: KDE neon 5.17
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Kernel Version: 5.0.0-36-generic
OS Type: 64-bit
Processors: 4 × Intel® Xeon® CPU E3-1225 V2 @ 3.20GHz
Memory: 23,5 GiB of RAM
Comment 1 raf 2019-12-07 23:50:23 UTC
I have been able to replicate this myself, current system:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Kernel Version: 5.3.12-1-MANJARO
OS Type: 64-bit

Appears to be a duplicate of https://bugs.kde.org/show_bug.cgi?id=411584. 

For me, it also worked for a while until I experimented with different night color settings, and then once I chose 'Times' as the operation mode, it became stuck. Same problem as Komorebi's.
Comment 2 raf 2019-12-07 23:57:21 UTC
For anyone searching online, there was a reference to this bug and a solution for users who encounter it, mentioned here: https://www.linuxquestions.org/questions/slackware-14/crash-accessing-display-and-monitor-settings-kde-ktown-5_19-0-a-4175662728/
Comment 3 Vlad Zahorodnii 2019-12-09 09:11:52 UTC

*** This bug has been marked as a duplicate of bug 411584 ***