Bug 414145 - Updates page: layout broken; size info covered by list of updates, which is not scrollable
Summary: Updates page: layout broken; size info covered by list of updates, which is n...
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Applications
Component: discover (show other bugs)
Version: 5.17.3
Platform: Archlinux Linux
: VHI grave
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
: 414334 414423 414449 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-14 17:49 UTC by John H
Modified: 2019-12-04 22:04 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.17.4


Attachments
Screenshot for Bug 414145 (54.25 KB, image/jpeg)
2019-11-17 14:40 UTC, John H
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John H 2019-11-14 17:49:33 UTC
SUMMARY
Important elements of updates screen covered by list of updates.

STEPS TO REPRODUCE
1. Click Updates Available icon in tray to open window to review updates
2. Maximize or resize window makes no difference to the fault
3. 

OBSERVED RESULT
List of updates covers total size info at top and covers scrollbar at side of window. I can, with luck pick up the fragment of scrollbar at the bottom and scroll all 100+ updates back to top and briefly see total update size box before the list springs back to the bottom. the size info and scrollbar still get covered even with only 5 or so updates in the list.

EXPECTED RESULT
Total update size at top of window, and scrollbar (if needed) visible at all times even if list is long and scrolls off the bottom.

SOFTWARE/OS VERSIONS

Arch Linux/KDE Plasma Desktop: Kernel Version: 5.3.11-arch1-1
(available in About System)
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2

ADDITIONAL INFORMATION
This report comes from an Arch Linux VBox guest but I have exactly the same issue on my Arch Linux host with KDE Plasma. Both systems are as of today fully up to date.
Comment 1 Nate Graham 2019-11-14 19:56:20 UTC
Can you attach a screenshot please?
Comment 2 Patrick Silva 2019-11-14 20:00:02 UTC
yes, the checkbox to check/uncheck all updates is not avaialble in Update page.
Comment 3 Nate Graham 2019-11-14 20:02:09 UTC
Oh, I know what this is. I have it too. If it's leaked into a release version... eek.
Comment 4 John H 2019-11-17 14:40:33 UTC
Created attachment 123969 [details]
Screenshot for Bug 414145

As requested, a screenshot for the bug.
I hope a picture says a thousand words!
Comment 5 Nate Graham 2019-11-17 15:06:23 UTC
Yep, I've got the same thing. We'll get it fixed, sorry for that. :(
Comment 6 Marco Martin 2019-11-19 16:34:24 UTC
Git commit 7c483074d0742340baf4414904188d80fd4d4c85 by Marco Martin.
Committed on 19/11/2019 at 16:31.
Pushed by mart into branch 'Plasma/5.17'.

don't overwrite mainItem

fixes scrolling

M  +1    -2    discover/qml/UpdatesPage.qml

https://commits.kde.org/discover/7c483074d0742340baf4414904188d80fd4d4c85
Comment 7 Patrick Silva 2019-11-20 21:21:56 UTC
*** Bug 414334 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2019-11-23 18:33:45 UTC
*** Bug 414423 has been marked as a duplicate of this bug. ***
Comment 9 postix 2019-11-24 13:21:22 UTC
*** Bug 414449 has been marked as a duplicate of this bug. ***
Comment 10 John H 2019-12-04 22:04:46 UTC
I just want to thank you guys, my plasma desktop on Arch was updated to version 5.17.4 on Tuesday. I'm happy to say the issue I reported has been fixed.
I couldn't tell on Tuesday because the issue involved the update process and I needed today's (Weds) round of updates to test it.
One day I'll get round to drawing you a beer with ASCII characters.