Bug 414121 - taskbar freezes if window title updates frequently
Summary: taskbar freezes if window title updates frequently
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.15.5
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: efficiency
Depends on:
Blocks:
 
Reported: 2019-11-14 04:12 UTC by ncdehnel
Modified: 2021-12-25 01:29 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ncdehnel 2019-11-14 04:12:57 UTC
SUMMARY
I have a KVM webpage that I use frequently. The KVM window's titlebar displays the remote server's refresh rate, which updates 60 times a second. Whenever I open the KVM my taskbar freezes. Put some sort of update cap, or some other mechanism to prevent the taskbar from freezing.

STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Operating System: Gentoo Linux 
KDE Plasma Version: 5.16.5
KDE Frameworks Version: 5.60.0
Qt Version: 5.12.3
Kernel Version: 5.2.0-gentoo
OS Type: 64-bit
Processors: 4 × Intel® Core™ i7-2670QM CPU @ 2.20GHz
Memory: 7.7 GiB of RAM


ADDITIONAL INFORMATION
Comment 1 David Edmundson 2020-02-26 01:04:39 UTC
A buffering cache was introduced into the task manager chain.

Is this still an issue?
Comment 2 Bug Janitor Service 2020-03-12 04:33:14 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 ncdehnel 2020-03-13 06:32:23 UTC
Yes, seems like it.

Operating System: Gentoo Linux 
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.67.0
Qt Version: 5.13.2
Kernel Version: 5.3.18-gentoo
OS Type: 64-bit
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 31.3 GiB of RAM
Comment 4 Bug Janitor Service 2020-03-28 04:33:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 ncdehnel 2020-03-28 08:08:22 UTC
update status
Comment 6 Bug Janitor Service 2021-11-02 04:14:31 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/675
Comment 7 Fushan Wen 2021-12-25 01:23:32 UTC
Git commit 1d612571c43b23cf829edfdae8eb7970812b5a32 by Fushan Wen.
Committed on 25/12/2021 at 01:11.
Pushed by fusionfuture into branch 'master'.

taskmanager: Only update the task label when visible

When the task label is not visible, we should not bind text to
model.display.

This is expected to slightly reduce the power consumption in daily usage.

M  +11   -1    applets/taskmanager/package/contents/ui/Task.qml

https://invent.kde.org/plasma/plasma-desktop/commit/1d612571c43b23cf829edfdae8eb7970812b5a32