Bug 414086 - Icon for Atom feed ignored
Summary: Icon for Atom feed ignored
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: feed parser (show other bugs)
Version: 5.12.3
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-13 07:32 UTC by Maarten ter Huurne
Modified: 2019-11-17 09:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten ter Huurne 2019-11-13 07:32:54 UTC
SUMMARY

If I add an Atom feed, the icon at the URL inside <icon> tag is not displayed.

STEPS TO REPRODUCE

1. Add feed: https://nasauber.de/blog/weblog.xml

I borrowed this URL from bug 111507. It looks like the problem described in the third comment of that bug is still present.

OBSERVED RESULT

A generic icon (globe) is displayed in front of the feed's entry.

When I test with my own feeds, the feed's icon URL is not even fetched from the web server. However, a fetch of "/favicon.ico" is attempted (result: 404) by the user agent "Konqueror/5", unlike the feed itself which is fetched by user agent "Akregator/5.12.3".

EXPECTED RESULT

The feed's icon is displayed in front of the feed's entry.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSUSE Leap 15.1
(available in About System)
KDE Plasma Version: 5.17.2
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.1

ADDITIONAL INFORMATION

Some Atom feeds do display icons for me, but I suspect these are loaded using the hardcoded "/favicon.ico" URL instead of from the URL in the <icon> tag.
Comment 1 Laurent Montel 2019-11-14 07:45:48 UTC
I confirm it.
I started to fix syndication for using <icon> tag + I need to fix akregator for using it.
Comment 2 Maarten ter Huurne 2019-11-17 08:41:14 UTC
Awesome!
Comment 3 Laurent Montel 2019-11-17 09:17:07 UTC
We need kf5.65 too.
but it works fine now.
I continue to fix akregator bug.