Bug 414075 - Net Worth Forecast Graph Beginning Incorrectly
Summary: Net Worth Forecast Graph Beginning Incorrectly
Status: RESOLVED DUPLICATE of bug 398982
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 5.0.7
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-12 20:49 UTC by bryan.williams7889
Modified: 2019-11-13 15:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of what was described. (88.88 KB, image/png)
2019-11-12 20:49 UTC, bryan.williams7889
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bryan.williams7889 2019-11-12 20:49:51 UTC
Created attachment 123874 [details]
Screenshot of what was described.

SUMMARY
It's looking like since KMyMoney 5, the starting date for the net worth graph seems to be stuck on the account opening date rather than the current date, resulting in a large dip at the beginning of the forecast. In KMyMoney 4, I think this actually started on the current day.

STEPS TO REPRODUCE
1. Open KMyMoney
2. Check that the Net Worth Forecast Graph is shown on the home page.
3. 

OBSERVED RESULT
The "Opening" amount seems to be the opening amount rather than the current day's, showing an inaccurate dip in the line graph. See attached screenshot.

EXPECTED RESULT
The forecast graph should start on the current day rather than the opening day years ago.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 4.14.81-1-lts
(available in About System)
KDE Plasma Version: 5.17.2
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.2

ADDITIONAL INFORMATION
N/A
Comment 1 Stefan Vater 2019-11-13 13:59:22 UTC
Yes, this was corrected recently. See:

https://bugs.kde.org/show_bug.cgi?id=398982

Stefan
Comment 2 Stefan Vater 2019-11-13 14:00:09 UTC
Yes, this was corrected recently. See:

https://bugs.kde.org/show_bug.cgi?id=398982

Stefan
Comment 3 Thomas Baumgart 2019-11-13 15:04:58 UTC

*** This bug has been marked as a duplicate of bug 398982 ***