Bug 414057 - [Wayland] Message viewer shows a black screen or is transparent under Wayland
Summary: [Wayland] Message viewer shows a black screen or is transparent under Wayland
Status: RESOLVED DUPLICATE of bug 397825
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 5.12.3
Platform: Other Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-12 09:25 UTC by tromzy
Modified: 2019-12-07 23:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tromzy 2019-11-12 09:25:02 UTC
SUMMARY
On Wayland, the message viewer in the main window of kmail displays either a black screen or the desktop (it is transparent). I use the Breeze default window theme.

STEPS TO REPRODUCE
1. Start Plasma Wayland
2. Start Kmail
3. 

OBSERVED RESULT
Message viewer is a black rectangle or shows what's beneath

EXPECTED RESULT
Message viewer should display the message.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.17.2
KDE Frameworks Version: 5.64
Qt Version: 5.13.2

ADDITIONAL INFORMATION
Arch Linux
Comment 1 Erik Boritsch 2019-11-24 21:44:01 UTC
Have the same issue with KDE Neon 5.17.3 with latest packages. The software versions are:

KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Kernel Version: 5.0.0.17-generic

The preview doesn't work in Kmail (also when Kmail is opened within Kontact), opening the mail in new window shows the proper content. Changing Composer setting didn't help. The graphics driver in use is i915.
Comment 2 John Scott 2019-12-07 23:45:53 UTC

*** This bug has been marked as a duplicate of bug 397825 ***