Bug 414013 - Kmail asks for password when gssapi should be used
Summary: Kmail asks for password when gssapi should be used
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-10 21:14 UTC by mgresko8@gmail.com
Modified: 2020-03-19 08:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mgresko8@gmail.com 2019-11-10 21:14:28 UTC
SUMMARY
When configuring kmail to connect to imap server using gssapi it asks for password. After entering valid password it successfully gets into mailbox. Kmail asks for password quite frequently.

After inspecting logs it can be seen kmail authenticated using gssapi and ticket for imap service have been generated.

Testing with evolution is successful.


OBSERVED RESULT

Kmail asks for password. Entering valid password enables mailbox access. entering invalid password does not enable.

EXPECTED RESULT
Single sign on using kerberos expected.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: 
kmail-19.04.3-2.fc31.x86_64
kf5-plasma-5.61.0-1.fc31.x86_64

Qt Version: 
qt-4.8.7-50.fc31.x86_64

ADDITIONAL INFORMATION
Comment 1 Christophe Marin 2019-11-26 08:26:51 UTC

*** This bug has been marked as a duplicate of bug 383279 ***
Comment 2 mgresko8@gmail.com 2019-12-30 13:57:12 UTC
This is not the same bug. The referenced bug mentions access is allowed after wrong password. For me it is not. And it has not been fixed in latest updates.
Comment 3 mgresko8@gmail.com 2020-01-15 20:34:30 UTC
Sorry, fedora packages are still on 19.04.3 version. So I did not verify whether the bug is fixed or not in 19.12.
Comment 4 mgresko8@gmail.com 2020-03-19 08:25:23 UTC
Hello,

I confirm the problem is fixed in 19.12.2 version.

Thanks

Marek