Bug 413942 - ksysguard crashed after forcefully closing a frozen Viber
Summary: ksysguard crashed after forcefully closing a frozen Viber
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.16.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-08 12:16 UTC by Silviu
Modified: 2019-12-01 14:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silviu 2019-11-08 12:16:24 UTC
Application: ksysguard (5.16.5)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-19-generic x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- What I was doing when the application crashed:
I sent a TERM signal to "Viber", then a KILL signal a few seconds later (Viber window was frozen). Viber windows closed on KILL. Viber processes dissapeard from the ksysguard list. Afterwards I closed the ksysguard window (everything seemed normal) and the crash handler poped up.

The crash does not seem to be reproducible.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb620789f00 (LWP 5004))]

Thread 3 (Thread 0x7fb617fff700 (LWP 5006)):
#0  0x00007fb633f61c2f in __GI___poll (fds=0x7fb6100029e0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fb62a31ea3e in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb62a31eb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb6325bb6c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fb63256263b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb63239ba75 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb6328e9efa in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fb63239ccc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fb62ab7a669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007fb633f6e323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fb61f8a3700 (LWP 5005)):
#0  0x00007fb633f61c2f in __GI___poll (fds=0x7fb61f8a25a8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fb62abdd917 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb62abdf53a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb61fe01288 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fb63239ccc2 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb62ab7a669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007fb633f6e323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fb620789f00 (LWP 5004)):
[KCrash Handler]
#6  0x00007fb6331f9810 in  () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#7  0x00007fb6331fa384 in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007fb6340b4223 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007fb633cde378 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007fb633ce5802 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007fb63258f5c8 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007fb6324df4ce in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007fb6324e5bd9 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fb6324e5f42 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007fb63258f468 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007fb63259c135 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fb63259c491 in QSocketNotifier::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007fb6330bea86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007fb6330c7e00 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007fb632563a9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007fb6325bc305 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fb62a31e84d in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fb62a31ead0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fb62a31eb73 in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fb6325bb6a5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fb63256263b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fb63256a3a6 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007fb6340b5fdf in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#29 0x00007fb633e731e3 in __libc_start_main (main=0x5638f2c2c060, argc=1, argv=0x7ffcd12808f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcd12808e8) at ../csu/libc-start.c:308
#30 0x00005638f2c2c09e in _start ()
[Inferior 1 (process 5004) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2019-12-01 14:34:06 UTC

*** This bug has been marked as a duplicate of bug 350140 ***