Bug 413528 - akonadi crashes after changing imap server
Summary: akonadi crashes after changing imap server
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.2
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-10-27 19:51 UTC by Bruno Friedmann
Modified: 2022-10-12 14:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (70.23 KB, patch)
2019-10-27 19:51 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2019-10-27 19:51:00 UTC
Application: akonadiserver (5.12.2)

Qt Version: 5.13.1
Frameworks Version: 5.63.0
Operating System: Linux 5.3.6-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: I moved (with imapsync) my email to a new server
openSUSE Tumbleweed dovecot 2.3.8
after changing the name of the server kmail & akonadi start behaving strangely with crash, or telling that the certificates has problem when no other programs (like thunderbird k9-mail and so on doesn't have)

Most to the crashes are not captured due to drkonqi crashing too.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#11 0x00007fd92d444ea3 in qTerminate () at global/qglobal.cpp:3252
#12 0x00007fd92d446900 in QThreadPrivate::start (arg=0x562e0a555930) at thread/qthread_unix.cpp:372
[...]


The reporter indicates this bug may be a duplicate of or related to bug 413205.

Possible duplicates by query: bug 413355, bug 413349, bug 413345, bug 413319, bug 413291.

Reported using DrKonqi
Comment 1 Bruno Friedmann 2019-10-27 19:51:01 UTC
Created attachment 123529 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Ahmad Samir 2020-08-18 09:28:03 UTC
The backtraces aren't very useful, but the error logs are much more informative in such cases (see ~/.xsession-errors or ~/.local/share/sddm/xorg-session.log for sddm users).
Comment 3 Justin Zobel 2022-10-12 03:49:54 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 4 Bruno Friedmann 2022-10-12 14:21:53 UTC
Closing not seen since a long time.
Works with at least
openSUSE Tumbleweed - 20220930
Linux 5.19.12-1-default x86_64 GNU/Linux 
nvidia: 515.65.01
Qt: 5.15.6
KDE Frameworks: 5.98.0
Plasma: 5.25.5
kmail2 5.21.1 (22.08.1)