Bug 413032 - Cancelling entering password shows an empty error box
Summary: Cancelling entering password shows an empty error box
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_sddm (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords: junior-jobs
: 388517 438587 449206 450427 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-16 12:19 UTC by bstallman99@gmail.com
Modified: 2022-06-04 22:38 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
Screenshot of the problem (215.04 KB, image/png)
2019-10-16 12:19 UTC, bstallman99@gmail.com
Details
screenshot of Plasma 5.21.2 (276.47 KB, image/png)
2021-03-07 12:42 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bstallman99@gmail.com 2019-10-16 12:19:49 UTC
Created attachment 123234 [details]
Screenshot of the problem

SUMMARY
Whenever you cancel the authorisation request to enter your password you just gen an empty error box

STEPS TO REPRODUCE
1. Open SDDM settings
2. Try changing something or applying the settings
3. Hit cancel on the password box

OBSERVED RESULT
An empty error box

EXPECTED RESULT
An error describing why you need to enter a password

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.17
KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.0.0-31-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6300HQ CPU @ 2.30GHz
Memory: 7.6 GiB of RAM

ADDITIONAL INFORMATION
Comment 1 Patrick Silva 2019-10-16 18:12:53 UTC
it seems related to bug 407686
Comment 2 Kai Uwe Broulik 2019-10-16 19:00:48 UTC
This looks like an easy (perhaps tedious because it's in a few places) fix.
There's a bunch of places where it uses calls exec() on a KAuth::ExecuteJob (e.g. in advancedconfig.cpp, sddkcm.cpp and themeconfig.cpp) but assumes that error() is always a failure. It should check for KAuth::ActionReply::UserCancelledError and then not show anything.
Comment 3 Ezike Ebuka 2021-03-07 05:17:43 UTC
this does not happen any longer on 

Plasma Version 5.21.1 

and Framework version 5,79
Comment 4 Patrick Silva 2021-03-07 12:42:39 UTC
Created attachment 136454 [details]
screenshot of Plasma 5.21.2

As we can see in the attached screenshot, on my system I get an empty inline message.

Operating System: Arch Linux
KDE Plasma Version: 5.21.2
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 5 Patrick Silva 2021-06-14 03:26:02 UTC
*** Bug 438587 has been marked as a duplicate of this bug. ***
Comment 6 Patrick Silva 2022-02-17 10:09:48 UTC
*** Bug 450427 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2022-05-24 19:27:34 UTC
Git commit c35bd4badba762d469bba5e8aa5e9e06bc1f3294 by Nate Graham, on behalf of oioi 555.
Committed on 24/05/2022 at 19:26.
Pushed by ngraham into branch 'master'.

Avoid empty error box

If the message is empty, hides the error box.

M  +1    -1    src/package/contents/ui/main.qml

https://invent.kde.org/plasma/sddm-kcm/commit/c35bd4badba762d469bba5e8aa5e9e06bc1f3294
Comment 8 Nate Graham 2022-05-24 19:49:46 UTC
Git commit a5d677955b550a1523248d6e819a4726b573625e by Nate Graham, on behalf of oioi 555.
Committed on 24/05/2022 at 19:49.
Pushed by ngraham into branch 'Plasma/5.25'.

Avoid empty error box

If the message is empty, hides the error box.


(cherry picked from commit c35bd4badba762d469bba5e8aa5e9e06bc1f3294)

M  +1    -1    src/package/contents/ui/main.qml

https://invent.kde.org/plasma/sddm-kcm/commit/a5d677955b550a1523248d6e819a4726b573625e
Comment 9 Nate Graham 2022-05-30 01:48:30 UTC
*** Bug 449206 has been marked as a duplicate of this bug. ***
Comment 10 Patrick Silva 2022-06-04 22:38:36 UTC
*** Bug 388517 has been marked as a duplicate of this bug. ***