Bug 413005 - Night Color settings break after switching to "Times" operation mode
Summary: Night Color settings break after switching to "Times" operation mode
Status: RESOLVED DUPLICATE of bug 411584
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_nightcolor (show other bugs)
Version: 5.17.0
Platform: Neon Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 413120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-15 21:57 UTC by Alex
Modified: 2019-10-29 20:27 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2019-10-15 21:57:24 UTC
SUMMARY
Switching to "Times" operation mode breaks night color settings and you can't save your new changes anymore or disable it. As a workaround you can remove the [NightColor] section from ~/.config/kwinrc, restart kwin and you'll be able to change settings normally again.

STEPS TO REPRODUCE
1. Access Night Color settings, for example by navigating to System Settings > Display and Monitor > Night Color
2. Enable Night Color and change Operation Mode to Times
3. Apply your changes and close the window (important)
4. Access Night Color settings again, make any new changes and try to apply them

OBSERVED RESULT
The Apply button is disabled and the OK button won't save new changes anymore.

EXPECTED RESULT
New changes should be able to be applied.

SOFTWARE/OS VERSIONS
KDE Neon Testing
KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.1
X11, proprietary nvidia drivers

ADDITIONAL INFORMATION
Output from running kcmshell5 nightcolor:

org.kde.kcoreaddons: Error loading plugin "kcm_nightcolor" "The shared library was not found." 
Plugin search paths are ("/usr/lib/x86_64-linux-gnu/qt5/plugins", "/usr/bin") 
The environment variable QT_PLUGIN_PATH might be not correctly set
gpsd not found
"location"
Fetching https://location.services.mozilla.com/v1/geolocate
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:71: TypeError: Cannot read property 'actions' of null
file:///usr/share/kpackage/kcms/kcm_nightcolor/contents/ui/main.qml:203:42: QML LocationsAutoView: Binding loop detected for property "implicitWidth"
file:///usr/share/kpackage/kcms/kcm_nightcolor/contents/ui/main.qml:191:42: QML TimingsView: Binding loop detected for property "implicitWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/private/ScrollView.qml:113:9: QML ScrollBar: Binding loop detected for property "visible"
Comment 1 Michael 2019-10-16 03:39:34 UTC
I can confirm, it happens to me too.

KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.3.6-arch1-1-ARCH
Xorg, xf86-video-amdgpu 19.0.1-1 driver.
Comment 2 Patrick Silva 2019-10-18 23:18:41 UTC
*** Bug 413120 has been marked as a duplicate of this bug. ***
Comment 3 Patrick Silva 2019-10-27 13:16:45 UTC
hum, I can't confirm this issue on my system.
But I noticed that "Apply" button remains enabled when clicked after I set operation mode to "Times"
despite the change is immediately applied after the first click on it.
The same occurs if operation mode is already "Times" and I modify any setting (sunrise/sunset times, transition duration, etc). Tested on both Wayland and X11 sessions.

Operating System: Arch Linux 
KDE Plasma Version: 5.17.1
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.3.7-arch1-1-ARCH
Comment 4 Yaroslav Sidlovsky 2019-10-28 20:43:21 UTC
Just reproduced this bug with plasma 5.17.1.

Operating System: Fedora 30
KDE Plasma Version: 5.17.1
KDE Frameworks Version: 5.63.0
Qt Version: 5.12.5
Kernel Version: 5.3.7-200.fc30.x86_64
OS Type: 64-bit
Processors: 4 × AMD FX(tm)-9590 Eight-Core Processor
Memory: 22,4 ГиБ
Comment 5 Vlad Zahorodnii 2019-10-29 10:24:43 UTC

*** This bug has been marked as a duplicate of bug 411584 ***
Comment 6 Vlad Zahorodnii 2019-10-29 16:58:17 UTC
(In reply to Patrick Silva from comment #3)
> hum, I can't confirm this issue on my system.
> But I noticed that "Apply" button remains enabled when clicked after I set
> operation mode to "Times"
> despite the change is immediately applied after the first click on it.
> The same occurs if operation mode is already "Times" and I modify any
> setting (sunrise/sunset times, transition duration, etc). Tested on both
> Wayland and X11 sessions.

Potential fix: https://phabricator.kde.org/D25047
Comment 7 Patrick Silva 2019-10-29 20:27:12 UTC
(In reply to Vlad Zahorodnii from comment #6)
> (In reply to Patrick Silva from comment #3)
> > hum, I can't confirm this issue on my system.
> > But I noticed that "Apply" button remains enabled when clicked after I set
> > operation mode to "Times"
> > despite the change is immediately applied after the first click on it.
> > The same occurs if operation mode is already "Times" and I modify any
> > setting (sunrise/sunset times, transition duration, etc). Tested on both
> > Wayland and X11 sessions.
> 
> Potential fix: https://phabricator.kde.org/D25047

I have just applied your patch on Neon unstable edition.
It fixes the issue. :)