Bug 412870 - Tags on splits are not shown in ledger view
Summary: Tags on splits are not shown in ledger view
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 5.0.2
Platform: Other All
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-12 08:30 UTC by Ralf Habacker
Modified: 2020-02-04 15:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.5
ralf.habacker: Version_5+


Attachments
test file (5.30 KB, application/x-kmymoney)
2019-10-12 08:30 UTC, Ralf Habacker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2019-10-12 08:30:59 UTC
Created attachment 123157 [details]
test file

SUMMARY


STEPS TO REPRODUCE
1. start kmymoney
2. load appended test file
3. open ledger or tag view

OBSERVED RESULT
The displayed transaction does not show the defined tag

EXPECTED RESULT
The displayed transation should show the defined tag
Comment 1 Michael Büker 2019-10-24 17:03:42 UTC
Also affects 4.8.4
Comment 2 Ralf Habacker 2019-10-25 07:02:03 UTC

*** This bug has been marked as a duplicate of bug 412429 ***
Comment 3 Ralf Habacker 2019-12-12 23:25:04 UTC
tag view display has been fixed with bug 412429; this bug is for the remaining ledger view.
Comment 4 Ralf Habacker 2019-12-13 00:01:18 UTC
Git commit ee1dd19a9af84a18cc5cffd0891bfd62eae43d2d by Ralf Habacker.
Committed on 13/12/2019 at 00:00.
Pushed by habacker into branch '4.8'.

Fix display of tags in ledger

Tags in splits were not displayed in the ledger view.
FIXED-IN:4.8.5

M  +57   -21   kmymoney/widgets/transaction.cpp
M  +6    -4    kmymoney/widgets/transaction.h

https://commits.kde.org/kmymoney/ee1dd19a9af84a18cc5cffd0891bfd62eae43d2d