Bug 412868 - Ksysguard crash on exit
Summary: Ksysguard crash on exit
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.16.90
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-12 07:01 UTC by Kishore Gopalakrishnan
Modified: 2019-11-01 20:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.08 KB, patch)
2019-11-01 10:13 UTC, Yan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kishore Gopalakrishnan 2019-10-12 07:01:50 UTC
Application: ksysguard (5.16.90)

Qt Version: 5.13.1
Frameworks Version: 5.62.0
Operating System: Linux 5.3.1-arch1-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
Ksysguard crashed when I was clsoing it. I haven't been able to reproduce it consistently, but the crash happens a few times each day.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f118a0beb00 (LWP 405359))]

Thread 4 (Thread 0x7f1181699700 (LWP 405362)):
#0  0x00007f119ecd6667 in poll () from /usr/lib/libc.so.6
#1  0x00007f1191f34130 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f1191f34201 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f119d3a5a1c in QEventDispatcherGlib::processEvents (this=0x7f1174000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f119d34c4ec in QEventLoop::exec (this=this@entry=0x7f1181698a70, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007f119d17e385 in QThread::exec (this=this@entry=0x7f119d708080 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007f119d684b37 in QDBusConnectionManager::run (this=0x7f119d708080 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#7  0x00007f119d17f5b0 in QThreadPrivate::start (arg=0x7f119d708080 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:360
#8  0x00007f119432557f in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f119ece10e3 in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f11832d0700 (LWP 405361)):
#0  0x00007f119432b415 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f118357bf5c in ?? () from /usr/lib/dri/i965_dri.so
#2  0x00007f118357bb58 in ?? () from /usr/lib/dri/i965_dri.so
#3  0x00007f119432557f in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f119ece10e3 in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f1189327700 (LWP 405360)):
#0  0x00007f119ecd6667 in poll () from /usr/lib/libc.so.6
#1  0x00007f119477d630 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f119477f2db in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f1189c41101 in QXcbEventQueue::run (this=0x5627ca9c7b70) at qxcbeventqueue.cpp:228
#4  0x00007f119d17f5b0 in QThreadPrivate::start (arg=0x5627ca9c7b70) at thread/qthread_unix.cpp:360
#5  0x00007f119432557f in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f119ece10e3 in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f118a0beb00 (LWP 405359)):
[KCrash Handler]
#6  0x00007f119df92f39 in QLabelPrivate::clearContents (this=this@entry=0x5627cae13d60) at widgets/qlabel.cpp:1302
#7  0x00007f119df93a9c in QLabel::setText (this=0x5627cadd00d0, text=...) at widgets/qlabel.cpp:293
#8  0x00007f119ee1dba4 in TopLevel::answerReceived (this=0x5627cadbbaf0, id=<optimized out>, answerList=...) at /home/kishore/build/build/ksysguard/src/ksysguard-5.16.90/gui/ksysguard.cpp:466
#9  0x00007f119ea7e0d8 in KSGRD::SensorAgent::processAnswer (this=0x5627caea6450, buf=<optimized out>, buflen=<optimized out>) at /home/kishore/build/build/libksysguard/src/libksysguard-5.16.90/ksgrd/SensorAgent.cpp:91
#10 0x00007f119ea857c0 in KSGRD::SensorShellAgent::msgRcvd (this=0x5627caea6450) at /usr/include/qt/QtCore/qarraydata.h:208
#11 0x00007f119d379b70 in QtPrivate::QSlotObjectBase::call (a=0x7ffd4e065780, r=0x5627caea6450, this=0x5627cae0fc90) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 QMetaObject::activate (sender=0x5627caf1acd0, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3789
#13 0x00007f119d2bff3b in QProcess::readyReadStandardOutput (this=this@entry=0x5627caf1acd0, _t1=...) at .moc/moc_qprocess.cpp:367
#14 0x00007f119d2c6982 in QProcessPrivate::tryReadFromChannel (this=0x5627cae038c0, channel=0x5627cae039e8) at io/qprocess.cpp:1078
#15 0x00007f119d2c6ce2 in QProcessPrivate::_q_canReadStandardError (this=<optimized out>) at io/qprocess.cpp:1097
#16 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffd4e065930) at .moc/moc_qprocess.cpp:210
#17 0x00007f119d379a11 in QMetaObject::activate (sender=0x5627caf273f0, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3809
#18 0x00007f119d386652 in QSocketNotifier::activated (this=this@entry=0x5627caf273f0, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:141
#19 0x00007f119d3869a2 in QSocketNotifier::event (this=0x5627caf273f0, e=0x7ffd4e065bf0) at kernel/qsocketnotifier.cpp:266
#20 0x00007f119de524f5 in QApplicationPrivate::notify_helper (this=this@entry=0x5627ca9aa1c0, receiver=receiver@entry=0x5627caf273f0, e=e@entry=0x7ffd4e065bf0) at kernel/qapplication.cpp:3703
#21 0x00007f119de5be11 in QApplication::notify (this=0x7ffd4e065ee0, receiver=0x5627caf273f0, e=0x7ffd4e065bf0) at kernel/qapplication.cpp:3449
#22 0x00007f119d34d9c2 in QCoreApplication::notifyInternal2 (receiver=0x5627caf273f0, event=0x7ffd4e065bf0) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:143
#23 0x00007f119d3a6656 in socketNotifierSourceDispatch (source=0x5627caa0d020) at kernel/qeventdispatcher_glib.cpp:107
#24 0x00007f1191f323ae in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x00007f1191f341c1 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x00007f1191f34201 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x00007f119d3a5a03 in QEventDispatcherGlib::processEvents (this=0x5627caa16810, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#28 0x00007f119d34c4ec in QEventLoop::exec (this=this@entry=0x7ffd4e065e10, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#29 0x00007f119d354326 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#30 0x00007f119d824cce in QGuiApplication::exec () at kernel/qguiapplication.cpp:1788
#31 0x00007f119de52466 in QApplication::exec () at kernel/qapplication.cpp:2859
#32 0x00007f119ee1fa03 in kdemain (argc=<optimized out>, argv=<optimized out>) at /home/kishore/build/build/ksysguard/src/ksysguard-5.16.90/gui/ksysguard.cpp:627
#33 0x00007f119ec0bee3 in __libc_start_main () from /usr/lib/libc.so.6
#34 0x00005627c8b5905e in _start ()
[Inferior 1 (process 405359) detached]
Comment 1 Yan 2019-11-01 10:13:28 UTC
Created attachment 123641 [details]
New crash information added by DrKonqi

ksysguard (5.17.2) using Qt 5.12.4

- What I was doing when the application crashed:

I use kubuntu backports ppa and kde applications 19.08 from kubuntu-staging ppa

-- Backtrace (Reduced):
#6  0x0000000000000571 in  ()
#7  0x00007f93a342c813 in  () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f93a342d384 in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007f93a42fbbb3 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#10 0x00007f93a3f253b8 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
Comment 2 Christoph Feck 2019-11-01 20:49:36 UTC

*** This bug has been marked as a duplicate of bug 350140 ***