Bug 412840 - Konsole doesn't honour accessibility setting 'flash window'
Summary: Konsole doesn't honour accessibility setting 'flash window'
Status: RESOLVED DUPLICATE of bug 407821
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 17.12.3
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-11 08:42 UTC by tim.baverstock
Modified: 2019-12-17 15:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tim.baverstock 2019-10-11 08:42:58 UTC
SUMMARY

Konsole doesn't honour the KDE accessibility setting 'flash window' - unlike all other terminals I've tried: xterm, Eterm, rxvt, gnome-terminal, IntelliJ's terminal panel.


STEPS TO REPRODUCE
1. Settings> System Settings> Personalisation> Accessibility> Use visual bell> Invert screen (actually, window).
2. Open a new Konsole
3. Press 'backspace' to cause a beep.

OBSERVED RESULT

Nothing at all. Not even a beep.

EXPECTED RESULT

It would trigger accessibility's beep logic and invert the window or whatever else is configured.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Ubuntu Ubuntu 18.04.3 LTS with kubuntu-desktop installed on top.
KDE Plasma Version: kde-plasma-desktop/bionic 5:100ubuntu2 amd64
KDE Frameworks Version: plasma-framework/bionic,now 5.44.0-0ubuntu3 amd64
Qt Version: qt4-default/bionic 4:4.8.7+dfsg-7ubuntu1 amd64 (qtchooser -print-env says 4)

ADDITIONAL INFORMATION

It clearly knows about the beep - I can add a notification to get it to announce one - but even with the notorious issues surrounding getting sound to work on Linux, it should honour the visual accessibilty setting at least as well as a non-KDE app.

I know I can add a command to trigger when the bell rings, but the point is that accessibility settings should just work. (xcalib -i is massive overkill)
Comment 1 Mariusz Glebocki 2019-11-04 02:22:03 UTC

*** This bug has been marked as a duplicate of bug 407821 ***
Comment 2 fire f. 2019-12-17 15:07:51 UTC
noticed it on Fedora 31 too