Bug 412490 - Breeze icon for SimpleScreenRecorder
Summary: Breeze icon for SimpleScreenRecorder
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Plasma
Component: Icons (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: visual-design
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-30 20:50 UTC by Unknown
Modified: 2022-12-25 03:26 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.101


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2019-09-30 20:50:02 UTC
The SimpleScreenRecorder is very popular, but not have a breeze icon.

Maybe repaint digiKam icon to make a SimpleScreenRecorder icon?
Comment 1 Vinzenz Vietzke 2019-12-08 23:44:16 UTC
I made an initial breeze version: https://phabricator.kde.org/D25820
Comment 2 Bug Janitor Service 2022-11-24 12:20:54 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/breeze-icons/-/merge_requests/229
Comment 3 Nate Graham 2022-11-25 05:43:32 UTC
Git commit 498af3e6d57bab73bd0f3cca339c946a61d587e0 by Nate Graham, on behalf of Manuel Jesús de la Fuente.
Committed on 25/11/2022 at 05:43.
Pushed by ngraham into branch 'master'.

Add SimpleScreenRecorder icon

![image](/uploads/f1f63a4f5a85636afe32f1770b177f1d/image.png)

![image](/uploads/d0c6189862516026711429a1afe4e690/image.png)

previous phab mr didn't migrate to invent: https://phabricator.kde.org/D25820

A  +48   -0    icons/apps/48/simplescreenrecorder.svg

https://invent.kde.org/frameworks/breeze-icons/commit/498af3e6d57bab73bd0f3cca339c946a61d587e0
Comment 4 agapito 2022-12-10 14:12:22 UTC
Thre is a problem here. After upgrading to KDE Frameworks 5.101 the recording and pause icons have disappeared from the system tray, so there is no way to know visually whether the program is recording or not.
Comment 5 Nate Graham 2022-12-10 15:10:49 UTC
Seems like a bug caused by the new Breeze icons.

That's a separate issue so please file a new bug report for it. Thanks!
Comment 6 Bug Janitor Service 2022-12-25 01:18:09 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/breeze-icons/-/merge_requests/234
Comment 7 Nate Graham 2022-12-25 03:26:17 UTC
Git commit 76ba10aada2b4a0d3f10342e908928646862b9e1 by Nate Graham.
Committed on 25/12/2022 at 01:16.
Pushed by ngraham into branch 'master'.

Revert "Add SimpleScreenRecorder icon"

This reverts commit 498af3e6d57bab73bd0f3cca339c946a61d587e0.

This breaks the tray icon changing its appearance based on the
recording/not recording status of the app.

The Breeze version of this icon is not thaaaaaat different from the
original, so on balance it's probably not worth it if we can't fix the
issue, which is not easily possible.
Related: bug 462905
FIXED-IN: 5.102

D  +0    -48   icons/apps/48/simplescreenrecorder.svg

https://invent.kde.org/frameworks/breeze-icons/commit/76ba10aada2b4a0d3f10342e908928646862b9e1