Bug 411435 - simply want to open my calendar
Summary: simply want to open my calendar
Status: RESOLVED DUPLICATE of bug 404275
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 5.10.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-08-30 03:35 UTC by Mathieu Jobin
Modified: 2019-08-30 11:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Jobin 2019-08-30 03:35:17 UTC
Application: korganizer (5.10.3)

Qt Version: 5.12.2
Frameworks Version: 5.61.0
Operating System: Linux 5.0.0-25-generic x86_64
Distribution: Ubuntu 19.04

-- Information about the crash:
- What I was doing when the application crashed:

I have not used korganizer in a long time
I believe I have some google backed calendar enabled.

now it crash on start everytime

I should probably try to disable those accounts from the settings and try again
but in anycase, it should not crash

The crash can be reproduced every time.

-- Backtrace:
Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f604c412a80 (LWP 25679))]

Thread 5 (Thread 0x7f603bfff700 (LWP 25686)):
#0  0x00007f6053bc9fb4 in __GI___libc_read (nbytes=16, buf=0x7f603bffe900, fd=11) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f6053bc9fb4 in __GI___libc_read (fd=11, buf=0x7f603bffe900, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f605130e410 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f60512c76cf in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f60512c7ba0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f60512c7d1c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f605416a063 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f60541155bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6053f602c6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6053f61612 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6051c14182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#11 0x00007f6053bdab1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f6048e86700 (LWP 25682)):
#0  0x00007f6053bc9fb4 in __GI___libc_read (nbytes=16, buf=0x7f6048e85900, fd=9) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f6053bc9fb4 in __GI___libc_read (fd=9, buf=0x7f6048e85900, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f605130e410 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f60512c76cf in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f60512c7ba0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f60512c7d1c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f605416a063 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f60541155bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6053f602c6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6053f61612 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6051c14182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#11 0x00007f6053bdab1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f604a097700 (LWP 25681)):
#0  0x00007f6053bce729 in __GI___poll (fds=0x7f603c018d80, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f60512c7bf6 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f60512c7d1c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f605416a063 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f60541155bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6053f602c6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f605381f565 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f6053f61612 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6051c14182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#9  0x00007f6053bdab1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f604b06c700 (LWP 25680)):
#0  0x00007f6053bce729 in __GI___poll (fds=0x7f604b06ba28, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f6051259917 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f605125b53a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f604bc476a8 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f6053f61612 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6051c14182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007f6053bdab1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f604c412a80 (LWP 25679)):
[KCrash Handler]
#6  0x00007f605400313a in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6053ffcc89 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6053fa662d in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6053fa6a7d in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6053fa7032 in QDateTime::QDateTime(QDate const&, QTime const&, QTimeZone const&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f605532d51a in KCalCore::MemoryCalendar::rawEvents(QDate const&, QDate const&, QTimeZone const&, bool) const () at /usr/lib/x86_64-linux-gnu/libKF5CalendarCore.so.5abi1
#12 0x00007f60552dff79 in KCalCore::Calendar::events(QDate const&, QDate const&, QTimeZone const&, bool) const () at /usr/lib/x86_64-linux-gnu/libKF5CalendarCore.so.5abi1
#13 0x00007f605567870c in  () at /usr/lib/x86_64-linux-gnu/libkorganizerprivate.so.5
#14 0x00007f6055679dc8 in  () at /usr/lib/x86_64-linux-gnu/libkorganizerprivate.so.5
#15 0x00007f6055671710 in  () at /usr/lib/x86_64-linux-gnu/libkorganizerprivate.so.5
#16 0x00007f605566b66f in  () at /usr/lib/x86_64-linux-gnu/libkorganizerprivate.so.5
#17 0x00007f605565f967 in CalendarView::CalendarView(QWidget*) () at /usr/lib/x86_64-linux-gnu/libkorganizerprivate.so.5
#18 0x000055a466829063 in  ()
#19 0x000055a46682a46a in  ()
#20 0x000055a46682aff3 in  ()
#21 0x00007f6055719c75 in KontactInterface::PimUniqueApplication::start(QStringList const&, bool) () at /usr/lib/x86_64-linux-gnu/libKF5KontactInterface.so.5
#22 0x000055a4668280f3 in  ()
#23 0x00007f6053ae3b6b in __libc_start_main (main=0x55a466827df0, argc=1, argv=0x7ffe611e2e18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe611e2e08) at ../csu/libc-start.c:308
#24 0x000055a4668282fa in _start ()
[Inferior 1 (process 25679) detached]

Reported using DrKonqi
Comment 1 Wolfgang Bauer 2019-08-30 11:25:06 UTC
(In reply to Mathieu Jobin from comment #0)
> Qt Version: 5.12.2

The debug symbols for Qt are missing, but the rest of the backtrace looks similar to bug#404275, which is actually a bug in Qt that was fixed in 5.12.3.

*** This bug has been marked as a duplicate of bug 404275 ***