Bug 411398 - Composer sometimes shows ambiguous question to discard message
Summary: Composer sometimes shows ambiguous question to discard message
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 5.9.3
Platform: Debian unstable Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-28 20:31 UTC by Johannes Zarl-Zierl
Modified: 2019-08-29 05:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
"Normal", correct dialog on the left, ambiguous dialog on the right (20.24 KB, image/png)
2019-08-28 20:31 UTC, Johannes Zarl-Zierl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Zarl-Zierl 2019-08-28 20:31:15 UTC
Created attachment 122406 [details]
"Normal", correct dialog on the left, ambiguous dialog on the right

SUMMARY
When closing the composer on an incomplete message, kmail presented me with an ambiguous dialog: "Do you want to discard the message or save it for later?" with the options Yes/No/Cancel.

After hitting cancel I could not trigger the incorrect behaviour again, but always got the correct dialog (same text, but options Save as draft/discard/cancel).

STEPS TO REPRODUCE
1. Close the composer window using a keyboard shortcut

OBSERVED RESULT
Possibly get the incorrect dialog buttons.

EXPECTED RESULT
Always get the correct dialog buttons.

SOFTWARE/OS VERSIONS
Betriebssystem: Debian GNU/Linux 
KDE-Plasma-Version: 5.14.5
Qt-Version: 5.11.3
KDE-Frameworks-Version: 5.54.0
Kernel-Version: 5.2.0-2-amd64
Art des Betriebssystems: 64-bit
Comment 1 Laurent Montel 2019-08-29 05:06:54 UTC
I can't reproduce this bug.
But 5.9.2 is very old. We release 5.12.0
Perhaps it's an old bug.

Could you test it on last version?
Reopen it if you can see it in last version.
Thanks