Bug 411391 - Segfault while opening diff
Summary: Segfault while opening diff
Status: RESOLVED DUPLICATE of bug 407745
Alias: None
Product: kdiff3
Classification: Unclassified
Component: application (show other bugs)
Version: 1.8.x
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: michael
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-28 16:55 UTC by Pastafarianist
Modified: 2019-11-26 02:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
core dump (66 bytes, text/plain)
2019-08-28 17:29 UTC, Pastafarianist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pastafarianist 2019-08-28 16:55:05 UTC
SUMMARY

KDiff3 crashes with a segfault while trying to open a diff for a file that only exists in A.


STEPS TO REPRODUCE

1. Ensure that you have Python's `cookiecutter` package (pip install --user cookiecutter).
2. Create a temporary directory where you will be testing everything (e.g. /temp/kdiff3-sigsegv) and cd into it.
3. Execute the following commands:

mkdir ccds
cd ccds
cookiecutter https://github.com/drivendata/cookiecutter-data-science  # call project "test" and answer other questions arbitrarily
cd ..
mkdir docker-ccds
cd docker-ccds
cookiecutter https://github.com/manifoldai/docker-cookiecutter-data-science  # call project "test" and answer other questions arbitrarily
cd ..
kdiff3 ccds/test docker-ccds/test

In KDiff3's interface, navigate to src/data/__init__.py and double-click on it.


OBSERVED RESULT

Segmentation fault. Here is backtrace from gdb:

#0  0x00007ffff72af665 in QAction::setEnabled(bool) () at /usr/lib/libQt5Widgets.so.5
#1  0x00005555555de9e5 in  ()
#2  0x00005555555aff7c in  ()
#3  0x00007ffff6929b70 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#4  0x00007ffff72f6fd4 in QWidget::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#5  0x00007ffff73a7b1f in QFrame::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#6  0x00007ffff73aa842 in QAbstractScrollArea::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#7  0x00007ffff752e8d4 in QAbstractItemView::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#8  0x00007ffff72b34d5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#9  0x00007ffff72bca21 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#10 0x00007ffff68fd9c2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#11 0x00007ffff72ba24f in QApplicationPrivate::setFocusWidget(QWidget*, Qt::FocusReason) () at /usr/lib/libQt5Widgets.so.5
#12 0x00007ffff72f0d28 in QWidget::setFocus(Qt::FocusReason) () at /usr/lib/libQt5Widgets.so.5
#13 0x00005555555b8adc in  ()
#14 0x00005555555b9925 in  ()
#15 0x00005555555bc02d in  ()
#16 0x000055555559b417 in  ()
#17 0x00007ffff6929b70 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#18 0x0000555555585cc4 in  ()
#19 0x000055555559f29f in  ()
#20 0x00007ffff6929b70 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#21 0x00007ffff75206e6 in QAbstractItemView::doubleClicked(QModelIndex const&) () at /usr/lib/libQt5Widgets.so.5
#22 0x00007ffff759de8d in QTreeView::mouseDoubleClickEvent(QMouseEvent*) () at /usr/lib/libQt5Widgets.so.5
#23 0x00007ffff72f6d5b in QWidget::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#24 0x00007ffff73a7b1f in QFrame::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#25 0x00007ffff752ea40 in QAbstractItemView::viewportEvent(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#26 0x00007ffff75a022c in QTreeView::viewportEvent(QEvent*) () at /usr/lib/libQt5Widgets.so.5
#27 0x00007ffff68fd6d3 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#28 0x00007ffff72b34c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#29 0x00007ffff72bcc6c in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#30 0x00007ffff68fd9c2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#31 0x00007ffff72bbd4b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () at /usr/lib/libQt5Widgets.so.5
#32 0x00007ffff7313211 in  () at /usr/lib/libQt5Widgets.so.5
#33 0x00007ffff7316154 in  () at /usr/lib/libQt5Widgets.so.5
#34 0x00007ffff72b34d5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#35 0x00007ffff72bca21 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#36 0x00007ffff68fd9c2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#37 0x00007ffff6c996d6 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () at /usr/lib/libQt5Gui.so.5
#38 0x00007ffff6c9b05b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib/libQt5Gui.so.5
#39 0x00007ffff6c7337c in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Gui.so.5
#40 0x00007ffff1d4ffec in  () at /usr/lib/libQt5XcbQpa.so.5
#41 0x00007ffff4a77cf4 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#42 0x00007ffff4a79b11 in  () at /usr/lib/libglib-2.0.so.0
#43 0x00007ffff4a79b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#44 0x00007ffff69559a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#45 0x00007ffff68fc5ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#46 0x00007ffff6904326 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#47 0x0000555555584f57 in  ()
#48 0x00007ffff61a3ee3 in __libc_start_main () at /usr/lib/libc.so.6
#49 0x00005555555854be in _start ()


SOFTWARE/OS VERSIONS
Manjaro Gnome (Linux 4.19.66-1-MANJARO #1 SMP PREEMPT Fri Aug 9 18:01:53 UTC 2019)
KDE Frameworks Version: 5.60.0
Qt Version: 5.13.0
KDiff3 1.8.1
Comment 1 Pastafarianist 2019-08-28 17:29:05 UTC
Created attachment 122404 [details]
core dump
Comment 2 michael 2019-11-26 02:21:03 UTC
Looks like the same crash in 407745 with better symbolics installed.

*** This bug has been marked as a duplicate of bug 407745 ***