Bug 411373 - Nextcloud calendar disappears
Summary: Nextcloud calendar disappears
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: monthview (show other bugs)
Version: 5.10.3
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-27 23:46 UTC by Thomas Tanghus
Modified: 2021-07-07 07:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2019-08-27 23:46:47 UTC
SUMMARY
I recently reinstalled/upgraded to Kubuntu 19.04, and wanted to see, if kde-pim stability had improved. I was first very pleasantly surprize-d - for a while. Now it's the calendar that's acting up.

I have 4 calendars in my Nextcloud instance. They all work fine in Thunderbird, Nextcloud web-client and to a certain degree in SailfishOS. 
Two times within a week, the calendar, where I keep the events (the others are for Tasks, Journal and Contact Birthdays) doesn't show any events in Month view.
First time I Shut down akonadi, removed every trace of the Nextcloud Akonadi agent, and recreated it.
It worked fine for a day or two, but now the events are not showing up in korganizer. Again, it shows perfectly fine in other clients, and I can see the events in akonadiconsole.

STEPS TO REPRODUCE
1. Configure a Nextcloud agent.
2. Wait

OBSERVED RESULT
The calendar disappears after some time.

EXPECTED RESULT
I should be able to use the calendar.

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 19.04
KDE Plasma Version: 5.16.4
KDE Frameworks Version: 5.61.0
Qt Version: 5.12.2
Kernel Version: 5.0.0-25-generic
OS Type: 64-bit
Processors: 4 × AMD Athlon(tm) 5350 APU with Radeon(tm) R3
Memory: 15,6 GiB of RAM

ADDITIONAL INFORMATION
Comment 1 Thomas Tanghus 2019-08-30 06:50:33 UTC
Now the calendar has decided to reappear. That's all good, maybe my Nextcloud instance was unavailable, but since the To-do view was able to deal with just the cached values, so should the month view be able to do that as well. Maybe sending a notification, that the backend is unavailable.
Comment 2 Michael K. 2020-07-07 10:58:41 UTC
Same here, running openSUSE on 2 PCs.

One of them:
Operating System: openSUSE Tumbleweed 20200630
KDE Plasma Version: 5.19.2
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Kernel Version: 5.7.5-1-default
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-4590 CPU @ 3.30GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 3 Thomas Tanghus 2020-07-07 18:49:17 UTC
Since then the situation has; improved may be to strong a word, but changed ;)
Now the calendars get deselected every once in a while. Akonadi/KOrganizer doesn't seem to try to reconnect to the server.

Operating System: Kubuntu 19.10
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.67.0
Comment 4 Michael K. 2020-07-08 16:10:12 UTC
With me it is the other way around. so far the calendars were still there, but not dialed. But now they're gone.
Comment 5 Riccardo Robecchi 2021-06-22 09:52:17 UTC
Is this bug still present? I have been using Nextcloud calendars for a while and they seem to work.
Comment 6 Michael K. 2021-06-22 16:13:26 UTC
Not lately. Think it's good now.
Comment 7 Bug Janitor Service 2021-07-07 04:33:46 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Thomas Tanghus 2021-07-07 06:31:03 UTC
It still happens once in a while here, but it's so rarely that I would say it works for me.
Comment 9 Riccardo Robecchi 2021-07-07 07:04:36 UTC
I'm closing this as solved then, thanks for the feedback.