Bug 411161 - Many KCM windows have insufficient padding around contents
Summary: Many KCM windows have insufficient padding around contents
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.16.4
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-08-22 11:12 UTC by Michael D
Modified: 2019-12-01 06:05 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.63


Attachments
KCM window with insufficient padding (42.18 KB, image/png)
2019-08-22 11:12 UTC, Michael D
Details
KCM window with sufficient padding (60.38 KB, image/png)
2019-08-22 11:13 UTC, Michael D
Details
drkonki on Neon unstable edition (96.43 KB, image/png)
2019-09-27 10:20 UTC, Patrick Silva
Details
old screenshot of drkonqi (36.49 KB, image/jpeg)
2019-09-27 10:21 UTC, Patrick Silva
Details
bluetooth kcm on neon unstable (29.22 KB, image/png)
2019-09-30 09:49 UTC, Marco Martin
Details
"Account assistant" of Kmail on Neon unstable edition (68.82 KB, image/png)
2019-10-21 14:39 UTC, Patrick Silva
Details
another affected window (164.56 KB, image/png)
2019-11-30 11:51 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael D 2019-08-22 11:12:29 UTC
When opening the kcm setting windows by themselves, many of them have (virtually) no padding. Some of them, however, do. This is with the window border size set to "no borders", which is the current default. They need padding. See the attached screenshots.
Comment 1 Michael D 2019-08-22 11:12:50 UTC
Created attachment 122290 [details]
KCM window with insufficient padding
Comment 2 Michael D 2019-08-22 11:13:09 UTC
Created attachment 122291 [details]
KCM window with sufficient padding
Comment 3 David Edmundson 2019-08-22 11:18:41 UTC
Please include your KDE frameworks version number (see kinfocenter)
Comment 4 Michael D 2019-08-22 11:20:08 UTC
KDE Frameworks Version: 5.61.0
Comment 6 David Edmundson 2019-08-22 13:45:23 UTC
Huh, that basically removes all of my ab33762a6a60101f6ddc5797e1620569f5a07a2a

which I did to fix this.
Comment 7 Nate Graham 2019-08-22 13:47:07 UTC
I think that commit was done to make multi-page KCMshell windows match the new sidebar style, but yeah, looks like it went a bit too far in some places.
Comment 8 Marco Martin 2019-09-19 10:09:01 UTC
Git commit 377a27db91e80aa01fdc680de7095665012f9b39 by Marco Martin.
Committed on 19/09/2019 at 10:06.
Pushed by mart into branch 'master'.

adjust margins of KCMultiDialog

margins are done differently depending whether there is one or more
pages

M  +10   -0    src/kcmultidialog.cpp

https://commits.kde.org/kcmutils/377a27db91e80aa01fdc680de7095665012f9b39
Comment 9 Michael D 2019-09-19 10:12:04 UTC
Thanks for the quick fix!
Comment 10 Nate Graham 2019-09-19 13:43:20 UTC
Hmm, this doesn't actually seem to be fixed. I can still reproduce it with the Bluetooth Adapters KCM, just like the original report.
Comment 11 Nate Graham 2019-09-19 13:54:58 UTC
never mind, there seems to be something wrong with my local install.
Comment 12 Patrick Silva 2019-09-27 10:20:05 UTC
Created attachment 122900 [details]
drkonki on Neon unstable edition

This issue persists with drkonqi on Neon unstable edition.
Comment 13 Patrick Silva 2019-09-27 10:21:06 UTC
Created attachment 122901 [details]
old screenshot of drkonqi
Comment 14 Marco Martin 2019-09-30 09:49:13 UTC
Created attachment 122946 [details]
bluetooth kcm on neon unstable

here how it looks on a just updated neon unstable, maybe was old packages?
Comment 15 Patrick Silva 2019-10-21 14:39:57 UTC
Created attachment 123380 [details]
"Account assistant" of Kmail on Neon unstable edition

bluetooth adapters kcm looks ok here too.
But the issue with drkonqi persists and, as we can see in the attached screenshot, "Account assistant" of Kmail is also affected.
Comment 16 Patrick Silva 2019-10-21 14:42:43 UTC
here is an old screnshot of Kmail
https://bugsfiles.kde.org/attachment.cgi?id=110004
Comment 17 Patrick Silva 2019-11-30 11:51:30 UTC
Created attachment 124203 [details]
another affected window

Can we reopen this issue?
Comment 18 Nate Graham 2019-12-01 06:05:20 UTC
It would be more useful to open individual new bugs about the windows that still have problems. This isn't something we can solve with one change; it will take multiple commits in different places to finally fix this properly.