Bug 411025 - Remove Dimming Effect on Windows, Move Title Bars
Summary: Remove Dimming Effect on Windows, Move Title Bars
Status: RESOLVED DUPLICATE of bug 303438
Alias: None
Product: kwin
Classification: Plasma
Component: effects-present-windows (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-17 22:38 UTC by Cameron Rodgers
Modified: 2021-01-08 20:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cameron Rodgers 2019-08-17 22:38:24 UTC
The dimming effect on windows in the Present Windows effect makes it harder to immediately recognize their contents, as they have less contrast with the dimmed background. This is compounded by the location of title bars (if they're enabled), right in the middle of the windows, obscuring their contents. The title bar location also makes the title bars harder to read too.

Here are some screenshots of similar effects in GNOME, Windows 10, and MacOS:
https://upload.wikimedia.org/wikipedia/en/c/c2/Shows_Overview_mode_%28%22Activities%22%29_in_GNOME_3.8.png
https://images.techhive.com/images/article/2015/07/taskview-100598415-orig.png
https://cdn.arstechnica.net/2011/07/04/lion/mission-control-big.png

As you can see, the dimming (if present) is not applied to the windows, and the title bars are either to the bottom or top. This is better for readability. I think that at very least, an option to apply this setting in the effect would improve KDE's looks and usability.
Comment 1 Nate Graham 2019-08-19 15:20:21 UTC

*** This bug has been marked as a duplicate of bug 385522 ***
Comment 2 Nate Graham 2021-01-08 20:06:02 UTC

*** This bug has been marked as a duplicate of bug 303438 ***