Bug 410874 - Clipboard: unproductive design
Summary: Clipboard: unproductive design
Status: RESOLVED DUPLICATE of bug 332512
Alias: None
Product: klipper
Classification: Applications
Component: plasma-widget (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-13 10:57 UTC by Aleksey Midenkov
Modified: 2019-08-13 16:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot_20190813_135542.jpeg (50.04 KB, image/jpeg)
2019-08-13 10:57 UTC, Aleksey Midenkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Midenkov 2019-08-13 10:57:14 UTC
Created attachment 122097 [details]
Screenshot_20190813_135542.jpeg

There only 6 items visible in list while it would be better to see 30-50 items. There is what can be done to improve productivity of tool (in order of importance):

1. Make configurable number of visible items or box vertical height;
2. Decrease vertical spacing between items;
3. Make configurable font, size;
4. It would be better to have different design apart from other applets: I'd like black text on white or gray background.

Please, implement at least 1 and 2, so it would be oriented for professional frequent usage.
Comment 1 Nate Graham 2019-08-13 16:14:28 UTC
1. Is covered by Bug 332512.
2. does not seem desirable as it would render the lists inconsistent with other lists (and we would receive bug reports about it), and also it would be moot if #1 is were implemented.
3. These are already configurable on a systemwide basis. Making them configurable on a per-applet basis as well would likewise introduce inconsistency that people would complain about, and require a ton of work for little benefit.
4. This would similarly make it inconsistent with everything else if it affected only the klipper applet. If you want dark text on a light background, you can use a light color scheme.

Since #1 is the only actionable item in the list and it is covered by Bug 332512, I'm marking this as a duplicate of Bug 332512.

*** This bug has been marked as a duplicate of bug 332512 ***