Bug 410313 - Wallpaper transition slightly effect darkens image during fade
Summary: Wallpaper transition slightly effect darkens image during fade
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Image Wallpaper (show other bugs)
Version: 5.16.4
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-28 14:10 UTC by piotr.intes
Modified: 2022-06-22 00:32 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
Wallpapers set that will demonstrate problem (200.33 KB, application/gzip)
2019-07-28 14:10 UTC, piotr.intes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description piotr.intes 2019-07-28 14:10:40 UTC
Created attachment 121796 [details]
Wallpapers set that will demonstrate problem

A am not totaly sure if this is right section, if not pleace move this post wherever it should be

SUMMARY

In previous version (tested with 5.12) wallpaper transition was just one image fading into another but in new version wallpaper gets darker before change. This is almost unnoticable in "normal use" but it is making some problems with any kind of automatic wallpaper changes or even worse problems when I am trying to make live wallpaper generation software - I need seamless transition for that.

STEPS TO REPRODUCE
1. Unpack archive I've sent you
2. Set wallpaper to slideshow, time for 2 seconds
3. Select unpacked folder as source (remove others if needed)


OBSERVED RESULT
Entire screen blinking upon every wallpaper change

EXPECTED RESULT
Dots lighting up and down randomly (works in Plasma 5.12)

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu, but will be tha same for all
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2019-08-05 00:28:45 UTC
Thank you very much for the very clear steps to reproduce and the example images. I can confirm that there is a darkening effect. I'm not aware of any intentional change here, so it may be a bug.
Comment 2 Nate Graham 2019-08-07 18:22:51 UTC
Pretty sure this was caused by https://cgit.kde.org/plasma-workspace.git/commit/wallpapers/image?id=f713a77e670aea28f560f0459ee78cf39f8e3c45

The new code should make it pretty easy to fix though.
Comment 3 Nate Graham 2019-08-08 18:51:42 UTC
There's a patch to fix this: https://phabricator.kde.org/D23021
Comment 4 piotr.intes 2019-08-09 09:45:20 UTC
Thanks for quick responce and fix :-)

It fixes the basic problem, but there still seams to be something more - once transition is finnished there is slight blink like if image is being redrawed after change. As I have observed the effect I think there is something like old wallpaper appearing back just before it gets removed (transition is alredy finnished and old wallpaper is still not removed).
Comment 5 Fushan Wen 2022-05-30 16:33:55 UTC
https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1630

Can you test if the blink still exists?
Comment 6 piotr.intes 2022-05-30 17:43:48 UTC
Works perfectly now :-D

Thank you
Comment 7 Fushan Wen 2022-06-22 00:32:16 UTC
Git commit 62cc13596805d712db6ad64de5d822893df58b22 by Fushan Wen.
Committed on 22/06/2022 at 00:25.
Pushed by fusionfuture into branch 'master'.

wallpapers/image: Hide background color when not needed

This avoids showing the background color during the transition.
FIXED-IN: 5.26

M  +3    -0    wallpapers/image/imagepackage/contents/ui/mediacomponent/BaseMediaComponent.qml

https://invent.kde.org/plasma/plasma-workspace/commit/62cc13596805d712db6ad64de5d822893df58b22