Bug 410308 - Possible to un-‘grey out’ option for downscaling to 8-bit for 8-bit images when separating colour channels
Summary: Possible to un-‘grey out’ option for downscaling to 8-bit for 8-bit images wh...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-28 08:12 UTC by Karl Ove Hufthammer
Modified: 2019-07-29 08:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Ove Hufthammer 2019-07-28 08:12:13 UTC
SUMMARY
When you try to separate the colour channels of an 8-bit image, the ‘Downscale to 8-bit before separating’ option is greyed out. This makes sense, since the image channels are already 8-bit channels. But by changing the ‘Output to color, not grayscale’ option *twice*, it’s possible to reenable the ‘Downscale to 8-bit before separating’ option. This should not be possible.


STEPS TO REPRODUCE
1. Create a new 8-bit document.
2. Select ‘Image → Separate Image’.
3. Select ‘Output to color, not grayscale’.
4. Deselect ‘Output to color, not grayscale’.

OBSERVED RESULT
‘Downscale to 8-bit before separating’ is no longer greyed out, and it is possible to enable the option.


EXPECTED RESULT
‘Downscale to 8-bit before separating’ should always be greyed out (and unselectable), since the image is already an 8-bit image.
 

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20190723
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.13.0
Kernel Version: 5.2.1-1-default
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2500 CPU @ 3.30GHz
Memory: 15,6 GiB
Comment 1 wolthera 2019-07-28 11:23:17 UTC
Git commit 73057eeac1f75c9a5f036aaa18b51c72816ab6f5 by Wolthera van Hövell tot Westerflier.
Committed on 28/07/2019 at 11:20.
Pushed by woltherav into branch 'master'.

The behaviour is now that on 8bit downscaling is always disabled.
On sixteen bit it is only possible when outputting to grayscale,
which is consistent with the actual code in kis_channel_seperation.

M  +9    -1    plugins/extensions/separate_channels/dlg_separate.cc
M  +2    -0    plugins/extensions/separate_channels/dlg_separate.h

https://invent.kde.org/kde/krita/commit/73057eeac1f75c9a5f036aaa18b51c72816ab6f5
Comment 2 Halla Rempt 2019-07-29 08:35:41 UTC
Git commit a2cbbe88383eab23f17bc7613dfe87c370d38f70 by Boudewijn Rempt, on behalf of Wolthera van Hövell tot Westerflier.
Committed on 29/07/2019 at 08:35.
Pushed by rempt into branch 'krita/4.2'.

The behaviour is now that on 8bit downscaling is always disabled.
On sixteen bit it is only possible when outputting to grayscale,
which is consistent with the actual code in kis_channel_seperation.

M  +9    -1    plugins/extensions/separate_channels/dlg_separate.cc
M  +2    -0    plugins/extensions/separate_channels/dlg_separate.h

https://invent.kde.org/kde/krita/commit/a2cbbe88383eab23f17bc7613dfe87c370d38f70