Bug 410265 - Bugs with application file type associations
Summary: Bugs with application file type associations
Status: RESOLVED WORKSFORME
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_filetypes (show other bugs)
Version: 5.16.3
Platform: Neon Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-27 08:25 UTC by Szyk Cech
Modified: 2019-11-14 04:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szyk Cech 2019-07-27 08:25:38 UTC
SUMMARY
There are few bugs in association apps with file types. This bugs is present in every KDE I used from 3.0 to current stable release in Neon!!!

The bugs are:
1. When I install View Your Mind (or Umberello) it does not associate it self with *.vym files.

2. When you right click in Krusader and chose "open with" and then chose app and click "remember". It do something, then it open file in decent program, but don't remember file association in KDE (when I close program and try open the same file again).

3. When I enter "System Settings" (form KDE), and go to the "Programs" and add new file type (e.g. Application/*.vym) and chose application for this file (eg. View Your Mind), and click save. It do something, but KDE does not remember this file association. Instead when I click (in Krusader) on the file it open applications tree and (stupidly) ask for app selection, and suprisingly when I chose my app and click "Remember" it correctly remember associated app to file (it open correctly file this time and every next).

This is strange as hell why such basic feature is so poorly supported in KDE?!? On Windows - which is lame due to lack file recognition by content - this feature always works as expected and newer fail!!!

STEPS TO REPRODUCE
As above.

OBSERVED RESULT
Failed to open file with associated app.

EXPECTED RESULT
1. Open file with associated app: After app installation (eg. VYM or Umbrello). Run chosen app after click on file matched pattern extension.

2. Easy associate app with file type: Right click on file *.vym, chose "Open with", chose app from app tree (eg. "View Your Mind"), click "Save". Run chosen app after click on file matched pattern extension.

3. Advanced associate app with file type: In "System Settings", click "Programs" or "Applications" (depend on translation), click "File associations", click file group (on tree), click "Add", type extension, chose app from apps tree, click save. Run chosen app after click on file matched pattern extension.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.16.3
(available in About System)
KDE Plasma Version: 5.16.3
KDE Frameworks Version: ?
Qt Version: ?

ADDITIONAL INFORMATION
I observe this problem in every KDE I used. I don't know why? Krusader do something wrong? If so: Why in System Settings, when I type file extension and chose app, and click save, then it can't open attached app to the file extension.
Comment 1 Szyk Cech 2019-07-28 18:54:05 UTC
The same problem is with CMakeLists.txt asociation with Qt Creator runing from Krusader. And the same work around works (open System Settings and add association CMakeLists.txt with Qt Creator, then go to Krusader and right click on CMakeLists.txt and chose Open In-> Ohter, then chose Qt Creator and click Remember and then Ok).
Comment 2 David Edmundson 2019-10-15 00:24:41 UTC
The bug described could be one of two things.

Either we do have a problem saving mime type associations, or the magic and mimedata for ymv is rwong.

We can test that by running 

"file /path/to/your/blah.ymv" and seeing what that returns.
Please then paste output here.
Comment 3 Bug Janitor Service 2019-10-30 04:33:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2019-11-14 04:33:10 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!