Bug 410224 - org.kde.plasma.notes widget crashes plasmashell
Summary: org.kde.plasma.notes widget crashes plasmashell
Status: RESOLVED WORKSFORME
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.3
Platform: unspecified Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-07-26 08:37 UTC by seed.no.zero
Modified: 2019-09-13 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-27530-0.html (1.47 KB, text/html)
2019-08-05 01:49 UTC, seed.no.zero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seed.no.zero 2019-07-26 08:37:08 UTC
Application: plasmashell (5.16.3)

Qt Version: 5.13.0
Frameworks Version: 5.60.0
Operating System: Linux 5.2.2-1-MANJARO x86_64
Distribution: "Manjaro Linux"

-- Information about the crash:
- What I was doing when the application crashed: I just click the widget org.kde.plasma.notes, which I wrote some commands or Urls in. Any way, then plasmashell crashes. I keep click note widget and plasmashell crashes again and again. It can automatically restart by itself for several times, but when I keep click note widget, it crashes without any restart action.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2e00265880 (LWP 31198))]

Thread 10 (Thread 0x7f2db7fff700 (LWP 31434)):
[KCrash Handler]
#6  0x00007f2e0277f677 in  () at /usr/lib/libfreetype.so.6
#7  0x00007f2e0277fd85 in  () at /usr/lib/libfreetype.so.6
#8  0x00007f2e0273ecdc in FT_Get_Char_Index () at /usr/lib/libfreetype.so.6
#9  0x00007f2dffe7479f in  () at /usr/lib/libQt5XcbQpa.so.5
#10 0x00007f2e0558f9e4 in QFontEngineMulti::stringToCMap(QChar const*, int, QGlyphLayout*, int*, QFlags<QFontEngine::ShaperFlag>) const () at /usr/lib/libQt5Gui.so.5
#11 0x00007f2e055b66f6 in QTextEngine::shapeText(int) const () at /usr/lib/libQt5Gui.so.5
#12 0x00007f2e055b73e7 in QTextEngine::shape(int) const () at /usr/lib/libQt5Gui.so.5
#13 0x00007f2e055bc75c in QTextEngine::shapeLine(QScriptLine const&) () at /usr/lib/libQt5Gui.so.5
#14 0x00007f2e055be9fc in  () at /usr/lib/libQt5Gui.so.5
#15 0x00007f2e055c55df in QTextLine::glyphRuns(int, int) const () at /usr/lib/libQt5Gui.so.5
#16 0x00007f2e06df07ea in  () at /usr/lib/libQt5Quick.so.5
#17 0x00007f2e06df0dde in  () at /usr/lib/libQt5Quick.so.5
#18 0x00007f2e06df2ea7 in  () at /usr/lib/libQt5Quick.so.5
#19 0x00007f2e06df49bd in  () at /usr/lib/libQt5Quick.so.5
#20 0x00007f2e06e1a29f in QQuickTextEdit::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () at /usr/lib/libQt5Quick.so.5
#21 0x00007f2e06d970a8 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /usr/lib/libQt5Quick.so.5
#22 0x00007f2e06d9796c in QQuickWindowPrivate::updateDirtyNodes() () at /usr/lib/libQt5Quick.so.5
#23 0x00007f2e06d98ef7 in QQuickWindowPrivate::syncSceneGraph() () at /usr/lib/libQt5Quick.so.5
#24 0x00007f2e06d3dd11 in  () at /usr/lib/libQt5Quick.so.5
#25 0x00007f2e06d3f0b5 in  () at /usr/lib/libQt5Quick.so.5
#26 0x00007f2e06d429d8 in  () at /usr/lib/libQt5Quick.so.5
#27 0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#28 0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#29 0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f2dd552c700 (LWP 31236)):
#0  0x00007f2e04431415 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f2e04f625a0 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f2e04f62692 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f2e06d427bd in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f2e06d42a6e in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f2dd693f700 (LWP 31223)):
#0  0x00007f2e033c94e4 in g_mutex_unlock () at /usr/lib/libglib-2.0.so.0
#1  0x00007f2e034171f2 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#2  0x00007f2e03418a28 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#4  0x00007f2e051819bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e04f5b2f5 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#7  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f2dd7140700 (LWP 31222)):
#0  0x00007f2e033c9479 in g_mutex_lock () at /usr/lib/libglib-2.0.so.0
#1  0x00007f2e03417206 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#2  0x00007f2e03418a28 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#4  0x00007f2e051819bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e04f5b2f5 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#7  0x00007f2dd758947a in  () at /usr/lib/qt/qml/QtQuick/XmlListModel/libqmlxmllistmodelplugin.so
#8  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f2dd7fff700 (LWP 31216)):
#0  0x00007f2e04bdc18c in read () at /usr/lib/libc.so.6
#1  0x00007f2e033c99f0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f2e03417311 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f2e03418a28 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f2e051819bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f2e04f5b2f5 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f2de4c3613b in KCupsConnection::run() () at /usr/lib/libkcupslib.so
#9  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f2de7fff700 (LWP 31213)):
#0  0x00007f2e04431415 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f2e04f625a0 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f2e04f62692 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f2e06d427bd in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f2e06d42a6e in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f2deecf0700 (LWP 31208)):
#0  0x00007f2e04431415 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f2deefe5ebc in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f2deefe5ab8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f2dfd468700 (LWP 31207)):
#0  0x00007f2e04bdc18c in read () at /usr/lib/libc.so.6
#1  0x00007f2e033c99f0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f2e03417311 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f2e03418a28 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f2e051819bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f2e04f5b2f5 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f2e069d98f9 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f2dfe72e700 (LWP 31206)):
#0  0x00007f2e04bdc18c in read () at /usr/lib/libc.so.6
#1  0x00007f2e033c99f0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f2e03417311 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f2e03418a28 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f2e051819bc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f2e04f5b2f5 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f2e059f9b37 in  () at /usr/lib/libQt5DBus.so.5
#9  0x00007f2e04f5c520 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f2e0442b57f in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f2e04beb0e3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f2e00265880 (LWP 31198)):
#0  0x00007f2e04431415 in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f2e04f625a0 in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /usr/lib/libQt5Core.so.5
#2  0x00007f2e04f62692 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#3  0x00007f2e06d40e2e in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f2e06d41c14 in  () at /usr/lib/libQt5Quick.so.5
#5  0x00007f2e06d4240b in  () at /usr/lib/libQt5Quick.so.5
#6  0x00007f2e054d334d in QWindow::event(QEvent*) () at /usr/lib/libQt5Gui.so.5
#7  0x00007f2e06da5c33 in QQuickWindow::event(QEvent*) () at /usr/lib/libQt5Quick.so.5
#8  0x00007f2e075186d4 in PlasmaQuick::Dialog::event(QEvent*) () at /usr/lib/libKF5PlasmaQuick.so.5
#9  0x00007f2e05c674d5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#10 0x00007f2e05c70a21 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#11 0x00007f2e051299c2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#12 0x00007f2e054c8d15 in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () at /usr/lib/libQt5Gui.so.5
#13 0x00007f2e054c8f48 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib/libQt5Gui.so.5
#14 0x00007f2e054a137c in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Gui.so.5
#15 0x00007f2dffdfffec in  () at /usr/lib/libQt5XcbQpa.so.5
#16 0x00007f2e03416cf4 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#17 0x00007f2e03418b11 in  () at /usr/lib/libglib-2.0.so.0
#18 0x00007f2e03418b51 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#19 0x00007f2e051819a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#20 0x00007f2e051285ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#21 0x00007f2e05130326 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#22 0x000055ffa1e45df6 in  ()
#23 0x00007f2e04b15ee3 in __libc_start_main () at /usr/lib/libc.so.6
#24 0x000055ffa1e462ae in _start ()
[Inferior 1 (process 31198) detached]

Reported using DrKonqi
Comment 1 David Edmundson 2019-07-26 10:34:53 UTC
>#8  0x00007f2e0273ecdc in FT_Get_Char_Index () at /usr/lib/libfreetype.so.6

Crash is in low level font stuff.

Do new notes crash or just opening your existing one.

Can you upload your ~/.config/plasma-org.kde.plasma.desktop-appletsrc
Comment 2 seed.no.zero 2019-08-05 01:49:18 UTC
Created attachment 121936 [details]
attachment-27530-0.html

Thx

On Fri, Jul 26, 2019, 18:34 David Edmundson <bugzilla_noreply@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=410224
>
> David Edmundson <kde@davidedmundson.co.uk> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>          Resolution|---                         |WAITINGFORINFO
>              Status|REPORTED                    |NEEDSINFO
>
> --- Comment #1 from David Edmundson <kde@davidedmundson.co.uk> ---
> >#8  0x00007f2e0273ecdc in FT_Get_Char_Index () at
> /usr/lib/libfreetype.so.6
>
> Crash is in low level font stuff.
>
> Do new notes crash or just opening your existing one.
>
> Can you upload your ~/.config/plasma-org.kde.plasma.desktop-appletsrc
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 Christoph Feck 2019-08-14 01:47:03 UTC
The attachment doesn't seem to contain the requested file. Please use this webpage instead of mail reply to add attachments.
Comment 4 Bug Janitor Service 2019-08-29 04:33:09 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2019-09-13 04:33:08 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!