Bug 410139 - Konsole not getting locale, print messages in spanish instead englisg
Summary: Konsole not getting locale, print messages in spanish instead englisg
Status: RESOLVED DUPLICATE of bug 192019
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 19.04.3
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-23 14:51 UTC by Luis Vivero Peña
Modified: 2021-10-16 12:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Vivero Peña 2019-07-23 14:51:06 UTC
SUMMARY
In the beginning I installed Kubuntu in spanish. Then I changed to english, so I can use the console output for documentation purposes. It works on GNOME with Wayland, but it fails on KDE Plasma, and it still print messages in spanish.

Locale output:

luis@starseedstation:~$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US:es
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

And I think that should be enough, right?



STEPS TO REPRODUCE
1. Install Kubuntu in spanish.
2. Change the environment to english.
3. Run any command that prints a system output:

sudo apt-get update

OBSERVED RESULT
luis@starseedstation:~$ sudo apt-get update
[sudo] contraseña para luis: 
Obj:1 https://repo.skype.com/deb stable InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                             
Obj:3 http://ppa.launchpad.net/ansible/ansible/ubuntu disco InRelease                                                    
Obj:4 https://download.docker.com/linux/ubuntu disco InRelease                  
Obj:5 http://dl.google.com/linux/chrome/deb stable Release                                            
Obj:6 http://archive.ubuntu.com/ubuntu disco InRelease                                                
Obj:7 http://archive.ubuntu.com/ubuntu disco-updates InRelease              
Obj:8 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu disco InRelease
Obj:10 http://archive.ubuntu.com/ubuntu disco-backports InRelease
Obj:11 http://archive.ubuntu.com/ubuntu disco-security InRelease
Leyendo lista de paquetes... Hecho

EXPECTED RESULT
I exepct the first two lines and also the last one in english, not spanish.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Kubuntu 19.04 / 5.0.0-21-generic
(available in About System)
KDE Plasma Version: KDE Plasma 5.16.3
KDE Frameworks Version: 5.60.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2019-07-23 16:38:42 UTC

*** This bug has been marked as a duplicate of bug 327757 ***
Comment 2 Nate Graham 2021-09-30 19:00:10 UTC

*** This bug has been marked as a duplicate of bug 192019 ***
Comment 3 Ahmad Samir 2021-10-16 12:10:45 UTC
Those two messages come from whatever terminal app you're running, Konsole just displays whatever the shell tells it to.