Bug 409981 - System monitor crash
Summary: System monitor crash
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.16.3
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-07-19 09:07 UTC by peter.lichard
Modified: 2019-08-05 20:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter.lichard 2019-07-19 09:07:00 UTC
Application: ksysguard (5.16.3)

Qt Version: 5.12.3
Frameworks Version: 5.60.0
Operating System: Linux 4.18.0-25-generic x86_64
Distribution: KDE neon User Edition 5.16

-- Information about the crash:
- What I was doing when the application crashed:
I was checking the memory usage of some applications on the System Monitor.
It was opened for a very long time, at least 20hours, and then I closed and re-opened it from the panel widget "System Load Viewer" quite quickly.
Some processes were reniced to a very low priority.

- Custom settings of the application:
* Panel on top of the screen.
* System Monitor shows memory usage in Mixed display units.

The crash does not seem to be reproducible.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2c034a4b80 (LWP 8231))]

Thread 4 (Thread 0x7f2bccf82700 (LWP 8234)):
#0  0x00007f2bf1322649 in g_mutex_lock () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2bf12db995 in g_main_context_prepare () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2bf12dc4fb in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2bf12dc6dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2bfe4c1dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f2bfe46303a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f2bfe28a4ca in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f2bfebcd015 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f2bfe28bc72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f2bf325c6db in start_thread (arg=0x7f2bccf82700) at pthread_create.c:463
#10 0x00007f2c02d9588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f2bcf1d1700 (LWP 8233)):
#0  0x00007f2bf32629f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x563efd944d28) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007f2bf32629f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x563efd944cd8, cond=0x563efd944d00) at pthread_cond_wait.c:502
#2  0x00007f2bf32629f3 in __pthread_cond_wait (cond=0x563efd944d00, mutex=0x563efd944cd8) at pthread_cond_wait.c:655
#3  0x00007f2bd04b53da in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f2bd04b5107 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f2bf325c6db in start_thread (arg=0x7f2bcf1d1700) at pthread_create.c:463
#6  0x00007f2c02d9588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f2bd894b700 (LWP 8232)):
#0  0x00007f2c02d88bf9 in __GI___poll (fds=0x7f2bd894a928, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f2bf3ab8747 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f2bf3aba36a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f2bdaa9a578 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f2bfe28bc72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f2bf325c6db in start_thread (arg=0x7f2bd894b700) at pthread_create.c:463
#6  0x00007f2c02d9588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f2c034a4b80 (LWP 8231)):
[KCrash Handler]
#6  0x00007f2bfe314aba in operator==(QString const&, QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f2bff8bb0c7 in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f2c030d8290 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007f2c02123b72 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f2c0212ac54 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f2bfe49498f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f2bfe3dfcea in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f2bfe3e6701 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f2bfe3e6bd0 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f2bfe494875 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f2bfe4a1178 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f2bfe4a1532 in QSocketNotifier::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f2bff78c65c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007f2bff793b90 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007f2bfe464d18 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f2bfe4c2a18 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f2bf12dc417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f2bf12dc650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f2bf12dc6dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f2bfe4c1daf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f2bfe46303a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007f2bfe46c170 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f2c030da18b in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#29 0x00007f2c02c95b97 in __libc_start_main (main=0x563efc871720, argc=1, argv=0x7ffe447d4488, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe447d4478) at ../csu/libc-start.c:310
#30 0x0000563efc87175a in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2019-08-05 20:13:59 UTC

*** This bug has been marked as a duplicate of bug 350140 ***