Bug 409793 - Just opening kcm fonts changes font settings!
Summary: Just opening kcm fonts changes font settings!
Status: RESOLVED DUPLICATE of bug 409518
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_fonts (show other bugs)
Version: 5.16.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on: 244857
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-14 15:35 UTC by Parag W
Modified: 2019-07-14 23:04 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Parag W 2019-07-14 15:35:03 UTC
+++ This bug was initially created as a clone of Bug #244857 +++


SUMMARY
I have Display scaling set to 1.5. I set that, restart and everything looks like it should. Then every time I open kcm fonts and close it without making any changes my fonts start looking crappy - they are tiny and anitaliasing is lost. Reopening the kcm fonts shows now Exclude Range is enabled and force fonts DPI is set to 96.

STEPS TO REPRODUCE
1. Set display scaling to 1.5 (not sure if this is needed to reproduce the isuse)
2. Open KCM Fonts - see that Exclude ranges is not initially enabled and neither is force fonts DPI.
3. Close and reopen KCM Fonts - now your fonts look garbled/tiny and for no reason Exclude Range is set and Force Fonts DPI is set to 96.

OBSERVED RESULT
Garbled Fonts

EXPECTED RESULT
Fonts the way they looked before you opened KCM Fonts.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.16.3
KDE Frameworks Version: 5.60.0
Qt Version: 5.13.0
Kernel Version: 5.2.0-arch2-1-ARCH
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 15.5 GiB of RAM

ADDITIONAL INFORMATION
Version:           Arch Linux Stable Packages
OS:                Arch Linux
Comment 1 Patrick Silva 2019-07-14 23:04:11 UTC

*** This bug has been marked as a duplicate of bug 409518 ***