Bug 409748 - Brush preset docker/dropdown only saves last used tag if when quiting krita the tag is not set to "All".
Summary: Brush preset docker/dropdown only saves last used tag if when quiting krita t...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Applications
Component: Tagging (show other bugs)
Version: git master (please specify the git hash!)
Platform: Archlinux Linux
: NOR minor
Target Milestone: ---
Assignee: Halla Rempt
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2019-07-12 16:36 UTC by Storm Engineer
Modified: 2019-11-15 10:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Storm Engineer 2019-07-12 16:36:20 UTC
Every time Krita starts the brush presets dropdown will have the tag "Textures" selected instead of All, or whatever it was left on.


STEPS TO REPRODUCE
1. Set the dropdown to All, or any tag
2. Restart Krita


OBSERVED RESULT

The dropdown is always reset to show the same tag


EXPECTED RESULT

The dropdown should either reset to All, or be left on the last used tag.


Krita

 Version: 4.3.0-prealpha (git 1766363)
 Languages: en_US
 Hidpi: false

Qt

  Version (compiled): 5.13.0
  Version (loaded): 5.13.0

OS Information

  Build ABI: x86_64-little_endian-lp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: linux
  Kernel Version: 5.1.16-arch1-1-ARCH
  Pretty Productname: Arch Linux
  Product Type: arch
  Product Version: unknown


Hardware Information

  GPU Acceleration: auto
  Memory: 16006 Mb
  Number of Cores: 8
Comment 1 Halla Rempt 2019-07-12 16:59:35 UTC
Sorry, but I cannot reproduce this.
Comment 2 Kapyia 2019-07-12 19:05:52 UTC
I'm having a similar experience, though for me the Brush Presets Docker always start at the Digital Atilier tag. And I know it's kept opening at the Pixel brush tag before. It seems like Krita just sporadically picks a tag and sticks to opening with that one for a while. Note that this is happening on my Windows 10 system.

I've held off reporting it since I know the entire resource system is being reworked.
Comment 3 Storm Engineer 2019-07-13 15:56:43 UTC
It maybe depending on how many tags you have.
Comment 4 vanyossi 2019-07-16 02:30:09 UTC
Brush preset docker/dropdown only saves las used tag if when quiting krita the tag is not set to "All".

Can you check this is the behaviour you are getting?
Comment 5 Storm Engineer 2019-07-17 15:17:22 UTC
I never use the tags, I always have it in All. Yet next run ut will show the "Textures" tag again.
Comment 6 Storm Engineer 2019-10-11 18:44:15 UTC
As of 4.3.0-prealpha (git 3e21da9), this issue is still present for me.
Comment 7 acc4commissions 2019-10-11 23:40:49 UTC
Did you try resetting krita by deleting kritarc file? 
I had the exact same issue and deleting the file fixed it.
Comment 8 vanyossi 2019-11-11 02:33:55 UTC
Git commit b0e82fe072a578cbc7ba4f5118d71433ae5d4430 by Ivan Yossi.
Committed on 11/11/2019 at 02:33.
Pushed by ivany into branch 'master'.

Allows preset "All" to be written in kritarc

This is a hack as resource manager is been rewritten.

M  +5    -3    libs/widgets/KoResourceTaggingManager.cpp

https://invent.kde.org/kde/krita/commit/b0e82fe072a578cbc7ba4f5118d71433ae5d4430
Comment 9 Halla Rempt 2019-11-15 10:36:05 UTC
Git commit 263b87c78d8c023bf247620287cfb56db6fdfe1b by Boudewijn Rempt, on behalf of Ivan Yossi.
Committed on 15/11/2019 at 10:10.
Pushed by rempt into branch 'krita/4.2'.

Allows preset "All" to be written in kritarc

This is a hack as resource manager is been rewritten.
(cherry picked from commit b0e82fe072a578cbc7ba4f5118d71433ae5d4430)

M  +5    -3    libs/widgets/KoResourceTaggingManager.cpp

https://invent.kde.org/kde/krita/commit/263b87c78d8c023bf247620287cfb56db6fdfe1b