Bug 409563 - Konsole does not send shift+tab (backtab) to terminal
Summary: Konsole does not send shift+tab (backtab) to terminal
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: keyboard (show other bugs)
Version: 19.04.2
Platform: Manjaro Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 402161 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-07 02:27 UTC by Radon Rosborough
Modified: 2019-08-23 15:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.08


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radon Rosborough 2019-07-07 02:27:50 UTC
SUMMARY
When I type shift+tab in Konsole, nothing happens. The terminal does not receive any key sequence (verify in Zsh by typing M-x describe-key-briefly and then shift+tab). This contradicts the default keyboard configuration, which says that Backtab+Ansi should generate the sequence I would expect, namely \E[Z. (I use this for cycling backwards through completion candidates in Zsh, as per https://stackoverflow.com/a/842370/3538165.)

STEPS TO REPRODUCE
1. Open Konsole
2. Run Zsh
3. Type M-x describe-key-briefly and then shift+tab.

OBSERVED RESULT
Nothing happens.

EXPECTED RESULT
I should at least see "undefined-key" from Zsh, indicating that a key sequence was sent to the terminal.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro, kernel 4.19.49
(available in About System)
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3

ADDITIONAL INFORMATION
Zsh: 5.7.1
Konsole: 19.04.2

Related but unhelpful bugs:
- https://bugs.kde.org/show_bug.cgi?id=284000
- https://bugs.kde.org/show_bug.cgi?id=402161
- https://bugs.kde.org/show_bug.cgi?id=175476
- https://forum.kde.org/viewtopic.php?f=225&t=141829
Comment 1 Mariusz Glebocki 2019-07-08 19:33:13 UTC
To make Shift+Tab work on 19.04, please remove Shift+Tab shortcut in Settings → Configure shortcuts (by default assigned to "Next View Container").
It is fixed on master.
Comment 2 Radon Rosborough 2019-07-09 01:10:07 UTC
Thanks, I can confirm that fixes the issue. It did not occur to me that there would be a place for customizing the behavior of the keyboard aside from Edit Current Profile > Keyboard. I now see that there are several different menu items for the settings; perhaps they could be unified to avoid confusion.
Comment 3 Nate Graham 2019-07-09 11:22:15 UTC
*** Bug 402161 has been marked as a duplicate of this bug. ***