Bug 409504 - Spinner shown while Discover loads screenshots is partially hidden
Summary: Spinner shown while Discover loads screenshots is partially hidden
Status: VERIFIED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.16.5
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
: 411278 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-04 20:03 UTC by Patrick Silva
Modified: 2019-10-09 14:42 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.17.0


Attachments
screenshot (145.29 KB, image/jpeg)
2019-07-04 20:03 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-07-04 20:03:21 UTC
Created attachment 121328 [details]
screenshot

STEPS TO REPRODUCE
1. Open Discover
2. click on some app to open its description page
3. 

OBSERVED RESULT
As we can see in the attached screenshot, Discover shows a partially hidden
spinner while loads the screenshots.

EXPECTED RESULT
The spinner is entirely visible.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.13
Comment 1 Nate Graham 2019-07-15 17:54:08 UTC
Confirmed in in widescreen mode.
Comment 2 Nate Graham 2019-07-15 18:52:37 UTC
Looks like the popup it's inside isn't popping up!

https://cgit.kde.org/discover.git/tree/discover/qml/ApplicationScreenshots.qml#n39
Comment 3 Patrick Silva 2019-09-20 21:30:18 UTC
*** Bug 411278 has been marked as a duplicate of this bug. ***
Comment 4 Aleix Pol 2019-10-09 14:13:45 UTC
Git commit 4dcf47831a2bd64b97365a4286a66a6a74b7c982 by Aleix Pol.
Committed on 09/10/2019 at 14:13.
Pushed by apol into branch 'Plasma/5.17'.

AppPage: Give some space to render screenshot busy indicators

M  +1    -1    discover/qml/ApplicationScreenshots.qml

https://commits.kde.org/discover/4dcf47831a2bd64b97365a4286a66a6a74b7c982