Bug 409390 - KDE System Settings -> Multimedia -> Audio Volume invisible tabs with QtCurve
Summary: KDE System Settings -> Multimedia -> Audio Volume invisible tabs with QtCurve
Status: RESOLVED FIXED
Alias: None
Product: frameworks-qqc2-desktop-style
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR major
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-02 02:01 UTC by S
Modified: 2019-09-16 10:31 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KDE System Settings -> Multimedia -> Audio Volume invisible tabs with QtCurve (71.07 KB, image/png)
2019-07-02 02:01 UTC, S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S 2019-07-02 02:01:44 UTC
Created attachment 121276 [details]
KDE System Settings -> Multimedia -> Audio Volume invisible tabs with QtCurve

Hi, on openSUSE Tumbleweed with all the latest Plasma / KDE / KF5 packages, the KDE Settings Audio configuration module has no tabs. (See attached screenshot.) With any other application theme the tabs display normally. Thanks!
Comment 1 Paul 2019-07-02 09:49:24 UTC
Able to confirm, using:

qtcurve-qt5: 1.9.0-2.2

Operating System: openSUSE Tumbleweed 20190630
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.13.0
Kernel Version: 5.1.10-1-default
OS Type: 64-bit
Comment 2 Nate Graham 2019-07-18 18:49:42 UTC
Cannot reproduce with Plasma 5.16.3 or git master on Manjaro.
Comment 3 Bruno Gonçalves 2019-09-09 21:15:10 UTC
I'm tried today with:
Manjaro and plasma 5.16.4
Kubuntu 19.10 and plasma 5.16.5
Kubuntu 19.04 and plasma 5.16.4

In all cases the error is present.
Comment 4 Elton Fabricio 2019-09-09 22:08:27 UTC
I'm tried today with:

Kubuntu 19.04 and plasma 5.16.4

The error is present.
Comment 5 Barnabedikartola 2019-09-10 21:57:49 UTC
I'm tried today with:

kubuntu 19.04 and plasma 5.16.4
KDE Neon and plasma 5.16.5

In all cases the error is present.
Comment 6 Bruno Gonçalves 2019-09-10 23:07:38 UTC
I more or less isolated the problem.

It occurs in some KDE windows using QML, I think everyone is using Kirigami.

In kubuntu 19.04 that comes with plasma 5.15.4 the problem does not exist, updating with PPA to 5.16.4 the problem appears.

One of the places where the problem occurs is in plasma-pa, the advanced volume dialog does not show tabs.

I kept all the updates and only installed the previous version of plasma-pa and the problem did not occur.

I updated plasma-pa and then just changed the file: /usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/main.qml

And it worked correctly.

From that point on, I don't know how to isolate the problem anymore, but I think we already have a good way to find exactly what is happening.
Comment 7 Kai Uwe Broulik 2019-09-16 10:31:44 UTC
Git commit bf14f6f0687e925dca27f5c5c36692ceecfe1b18 by Kai Uwe Broulik.
Committed on 16/09/2019 at 10:31.
Pushed by broulik into branch 'master'.

[Tab] Fix sizing

Replicates QTabBar::tabSizeHint for desktop style. Not every style implements custom size hints for tabs,
where it would just fall through to returning sizeFromContents as it is passed in, leading to tiny tabs.

Differential Revision: https://phabricator.kde.org/D22213

M  +21   -2    plugin/kquickstyleitem.cpp

https://commits.kde.org/qqc2-desktop-style/bf14f6f0687e925dca27f5c5c36692ceecfe1b18